summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 21:12:49 +0200
committerDavid Craven <david@craven.ch>2016-08-18 13:06:20 +0200
commit5801d21fd4a42cb3b8720b2da43e240430b468ad (patch)
tree64d04f0ecba6981ee6e0f1231dfac403b80a48dd /gnu/packages/kde-frameworks.scm
parentb2ac012d04e1978eabd3f9c4a60e5ba4b2fd8767 (diff)
downloadguix-patches-5801d21fd4a42cb3b8720b2da43e240430b468ad.tar
guix-patches-5801d21fd4a42cb3b8720b2da43e240430b468ad.tar.gz
gnu: Add knotifications.
* gnu/packages/kde-frameworks.scm (knotifications): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 428a5251ed..0e39a4a56c 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1290,3 +1290,45 @@ formats.")
(description "KJobWIdgets provides widgets for showing progress of
asynchronous jobs.")
(license license:lgpl2.1+)))
+
+(define-public knotifications
+ (package
+ (name "knotifications")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0qryp41phnpx4r9wa6rfhmnzy7nxl0ijnyrafadf2n2xb53ipkpa"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("dbus" ,dbus)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("kcodecs" ,kcodecs)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("phonon" ,phonon)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda* _
+ (setenv "HOME" (getcwd))))
+ (replace 'check
+ (lambda* _
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (zero? (system* "dbus-launch" "ctest" ".")))))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Desktop notifications")
+ (description "KNotification is used to notify the user of an event. It
+covers feedback and persistent events.")
+ (license license:lgpl2.1+)))