summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-04-03 21:08:46 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-04-12 10:08:52 +0200
commit1aab5e8320292f9414e1289173b5781422da3f14 (patch)
treed3ef285b82276b59cd42950418838bb5309d5103 /gnu/packages/kde-frameworks.scm
parent4467c2d1dcbf88e26767616a49ed49de8ee48f57 (diff)
downloadguix-patches-1aab5e8320292f9414e1289173b5781422da3f14.tar
guix-patches-1aab5e8320292f9414e1289173b5781422da3f14.tar.gz
gnu: kde-frameworks: No longer setenv CTEST_OUTPUT_ON_FAILURE.
This is now done my the cmake-build-system. * gnu/packages/kde-frameworks.scm (kcoreaddons, kwidgetsaddons, kpackage, kemoticons kiconthemes, kio, knewstuff, kpeople, krunner,kservice, ktexteditor, kxmlgui plasma-framework) [arguments] <check-setup>: Remove setenv CTEST_OUTPUT_ON_FAILURE. (kpty) [arguments] <patch-tests>: Remove setenv CTEST_OUTPUT_ON_FAILURE. (ksyntaxhighlighting) [arguments] <check-setup>: Remove phase.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 2c263e4718..78654a1cd3 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -536,7 +536,6 @@ propagate their changes to their respective configuration files.")
(modify-phases %standard-phases
(add-before 'check 'check-setup
(lambda _
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; enable debug output
(setenv "HOME" (getcwd))
(setenv "TMPDIR" (getcwd))
#t)))))
@@ -902,10 +901,6 @@ pixel units.")
(substitute* '("autotests/input/highlight.pl"
"autotests/folding/highlight.pl.fold")
(((which "perl")) "/usr/bin/perl"))
- #t))
- (add-before 'check 'check-setup
- (lambda _
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; enable debug info
#t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Syntax highlighting engine for Kate syntax definitions")
@@ -983,7 +978,6 @@ represented by a QPoint or a QSize.")
(lambda _
;; make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; enable debug info
(setenv "DBUS_FATAL_WARNINGS" "0")
#t))
(add-before 'check 'start-xorg-server
@@ -1572,7 +1566,6 @@ covers feedback and persistent events.")
(modify-phases %standard-phases
(add-before 'check 'check-setup
(lambda _
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; enable debug output
(setenv "HOME" (getcwd))
#t)))))
(home-page "https://community.kde.org/Frameworks")
@@ -1608,7 +1601,6 @@ were traditional plugins.")
(modify-phases %standard-phases
(add-after 'unpack 'patch-tests
(lambda _
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
(substitute* "autotests/kptyprocesstest.cpp"
(("/bin/bash") (which "bash")))
#t)))))
@@ -2113,7 +2105,6 @@ with su and ssh respectively.")
(add-before 'check 'check-setup
(lambda _
(setenv "HOME" (getcwd))
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; Enable debug output
;; make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
#t)))))
@@ -2207,7 +2198,6 @@ window does not need focus for them to be activated.")
(string-append (assoc-ref inputs "shared-mime-info")
"/share"))
(setenv "HOME" (getcwd))
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; Enable debug output
;; make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
#t)))))
@@ -2316,7 +2306,6 @@ makes starting KDE applications faster and reduces memory consumption.")
(lambda _
(setenv "HOME" (getcwd))
(setenv "XDG_RUNTIME_DIR" (getcwd))
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
;; make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
#t)))))
@@ -2382,7 +2371,6 @@ KIO enabled infrastructure.")
(add-before 'check 'check-setup
(lambda _ ; XDG_DATA_DIRS isn't set
(setenv "HOME" (getcwd))
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
;; make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
#t)))))
@@ -2517,7 +2505,6 @@ widgets with a user-interface defined in terms of actions.")
(modify-phases %standard-phases
(add-before 'check 'check-setup
(lambda _
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; Enable debug output
;; make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
#t)))))
@@ -2574,7 +2561,6 @@ to easily extend the contacts collection.")
(modify-phases %standard-phases
(add-before 'check 'check-setup
(lambda _
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; Enable debug output
;; make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
#t)))))
@@ -2620,7 +2606,6 @@ typed.")
(add-before 'check 'check-setup
(lambda _
(setenv "HOME" (getcwd))
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
;; make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
#t)))))
@@ -2691,7 +2676,6 @@ types or handled by application specific code.")
(setenv "HOME" (getcwd))
;; make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
#t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Full text editor component")
@@ -2830,7 +2814,6 @@ the passwords on KDE work spaces.")
(setenv "HOME" (getcwd))
;; make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
#t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Framework for managing menu and toolbar actions")
@@ -2940,7 +2923,6 @@ setUrl, setUserAgent and call.")
(add-before 'check 'check-setup
(lambda _
(setenv "HOME" (getcwd))
- (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; Enable debug output
;; make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
#t)))))