summaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-18 21:52:18 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-18 23:08:29 +0200
commit2cde4a967d162dc46cc1f6967ed21b196c14c338 (patch)
treef647621d89fec5f161b83464da2a5fffbd2ec114 /gnu/packages/jupyter.scm
parentaf632c6b70feaf83c534fa282904b5fdf6f6f919 (diff)
downloadguix-patches-2cde4a967d162dc46cc1f6967ed21b196c14c338.tar
guix-patches-2cde4a967d162dc46cc1f6967ed21b196c14c338.tar.gz
gnu: Add python-jupyter-protocol.
* gnu/packages/jupyter.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
new file mode 100644
index 0000000000..c7c1318808
--- /dev/null
+++ b/gnu/packages/jupyter.scm
@@ -0,0 +1,57 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages jupyter)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system python)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages time))
+
+(define-public python-jupyter-protocol
+ (package
+ (name "python-jupyter-protocol")
+ (version "0.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyter_protocol" version))
+ (sha256
+ (base32
+ "1bk3as5yw9y5nmq6l15nr46aby34phmvsx9kxgqnm5pd5q2b5h57"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-dateutil" ,python-dateutil)
+ ("python-jupyter-core" ,python-jupyter-core)
+ ("python-pyzmq" ,python-pyzmq)
+ ("python-traitlets" ,python-traitlets)))
+ (native-inputs
+ `(("python-ipykernel" ,python-ipykernel)
+ ("python-ipython" ,python-ipython)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://jupyter.org")
+ (synopsis "Jupyter protocol implementation")
+ (description
+ "This Python library is an experimental implementation of the
+@uref{https://jupyter-client.readthedocs.io/en/latest/messaging.html, Jupyter
+protocol} to be used by both clients and kernels.")
+ (license license:bsd-3)
+ (properties '((upstream-name . "jupyter_protocol")))))