summaryrefslogtreecommitdiff
path: root/gnu/packages/julia.scm
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2023-04-13 22:24:45 +0200
committerAndreas Enge <andreas@enge.fr>2023-04-14 17:14:51 +0200
commit1e28aed2eb7049c8a40092071ac1ca1142869b6d (patch)
tree341ff906051845fa2b75ea87d3de62671ee8ca19 /gnu/packages/julia.scm
parent31dd526e1cfc3a70c72c8906bef8f26b91f39ce4 (diff)
downloadguix-patches-1e28aed2eb7049c8a40092071ac1ca1142869b6d.tar
guix-patches-1e28aed2eb7049c8a40092071ac1ca1142869b6d.tar.gz
gnu: julia: Fix test suite regression.
The update of 'mpfr' to 4.2.0 by commit d26814f8b936911d48bb004093713a525f2c6cf8 introduces a Julia test suite regression. The patch backports the Julia upstream fix. * gnu/packages/julia.scm (julia)[source]: Add patch. * gnu/packages/patches/julia-Use-MPFR-4.2.patch: New file. * gnu/local.mk: Add it. Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/julia.scm')
-rw-r--r--gnu/packages/julia.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 906cb4b94c..ba54175822 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -150,7 +150,8 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
(sha256
(base32
"0jf8dr5j7y8cjnr65kn38xps5h9m2qvi8g1yd8qgiip5r87ld3ad"))
- (patches (search-patches "julia-SOURCE_DATE_EPOCH-mtime.patch"))))
+ (patches (search-patches "julia-SOURCE_DATE_EPOCH-mtime.patch"
+ "julia-Use-MPFR-4.2.patch"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"