summaryrefslogtreecommitdiff
path: root/gnu/packages/julia.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-13 15:12:52 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-13 19:43:25 +0100
commitdb2f95f1c24f5bfd05aa4c062cc6e7a32088345c (patch)
tree0680435d9c778ca0ba56da496d6ddd6a71a7815a /gnu/packages/julia.scm
parent37ba374a536453078a5ba9e81815902b256884c0 (diff)
downloadguix-patches-db2f95f1c24f5bfd05aa4c062cc6e7a32088345c.tar
guix-patches-db2f95f1c24f5bfd05aa4c062cc6e7a32088345c.tar.gz
gnu: libwhich: Compile natively, too.
This follows up on commit 12424b3ecfdf401c72804ddfa4b2fa2d8b1b68e5. * gnu/packages/julia.scm (libwhich)[arguments]: Fix non-cross compilation.
Diffstat (limited to 'gnu/packages/julia.scm')
-rw-r--r--gnu/packages/julia.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 5cb4e53140..d8a6d7ac2f 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -201,9 +201,10 @@
(modify-phases %standard-phases
(delete 'configure)
(add-before 'check 'set-ld-library-path
- (lambda* (#:key native-inputs #:allow-other-keys)
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
(setenv "LD_LIBRARY_PATH"
- (string-append (assoc-ref native-inputs "zlib") "/lib"))))
+ (string-append (assoc-ref (or native-inputs inputs) "zlib")
+ "/lib"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))