summaryrefslogtreecommitdiff
path: root/gnu/packages/julia.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-07 09:08:49 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-07 09:10:44 +0300
commit8333673c4c33d269139ded0d9f67d99f6369f736 (patch)
treecac77dfc8d0e340b5c4a11e32d3773731ca2b3d1 /gnu/packages/julia.scm
parent4b4d4d7baef00df6e5b8ee14359195292fd37e36 (diff)
downloadguix-patches-8333673c4c33d269139ded0d9f67d99f6369f736.tar
guix-patches-8333673c4c33d269139ded0d9f67d99f6369f736.tar.gz
gnu: julia: Adjust make-flags.
* gnu/packages/julia.scm (julia)[arguments]: Adjust architecture specific make-flags for some architectures.
Diffstat (limited to 'gnu/packages/julia.scm')
-rw-r--r--gnu/packages/julia.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 13c9f7baf1..abefc388bc 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -377,10 +377,12 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
(%current-system))
("x86_64-linux" "MARCH=x86-64")
("i686-linux" "MARCH=pentium4")
- ("aarch64-linux" "MARCH=armv8-a")
+ ("armhf-linux" "JULIA_CPU_TARGET=armv7-a,neon")
+ ("powerpc64le-linux" "JULIA_CPU_TARGET=pwr8")
;; Prevent errors when querying this package on unsupported
;; platforms, e.g. when running "guix package --search="
- (_ "MARCH=UNSUPPORTED"))
+ ;; and also of targeting the builder's architecture.
+ (_ "JULIA_CPU_TARGET=generic"))
"CONFIG_SHELL=bash" ;needed to build bundled libraries
;; list of "USE_SYSTEM_*" is here: