summaryrefslogtreecommitdiff
path: root/gnu/packages/julia.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-05 19:41:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-06 16:29:29 +0300
commit8822ee1775e1d0bf0389ccb7f09ba85bb7535222 (patch)
tree43f12d2551a0f49914921e33b33f2b1e880d656d /gnu/packages/julia.scm
parent1711f529312792ed9cfd5656d166d4f466f6d48d (diff)
downloadguix-patches-8822ee1775e1d0bf0389ccb7f09ba85bb7535222.tar
guix-patches-8822ee1775e1d0bf0389ccb7f09ba85bb7535222.tar.gz
gnu: julia: Update to 1.6.2.
* gnu/packages/julia.scm (julia): Update to 1.6.2. [arguments]: Add phase to adjust the expected number of precompile statements. Adjust custom 'disable-broken-tests phase to remove fixed test. [native-inputs]: Remove nss-certs.
Diffstat (limited to 'gnu/packages/julia.scm')
-rw-r--r--gnu/packages/julia.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 4d739c8434..fe31e545c9 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -32,7 +32,6 @@
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages base)
- #:use-module (gnu packages certs)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages elf)
@@ -273,7 +272,7 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
(define-public julia
(package
(name "julia")
- (version "1.6.1")
+ (version "1.6.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -281,7 +280,7 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
version "/julia-" version ".tar.gz"))
(sha256
(base32
- "1mfzbjyqcmx7wb1sa7qab5fl78yzd7ap088krqbphbwvpn880srn"))
+ "0plbj4laifzz8ppk889iv3gaxj1mdddzv7yad6ghml6bfnn24r6m"))
(patches
(search-patches "julia-SOURCE_DATE_EPOCH-mtime.patch"))))
(build-system gnu-build-system)
@@ -341,6 +340,13 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
(("\\$\\$\\(build_depsbindir\\)/libwhich")
(string-append (assoc-ref inputs "libwhich") "/bin/libwhich")))
#t))
+ (add-after 'unpack 'change-number-of-precompile-statements
+ (lambda _
+ ;; Remove nss-certs drops the number of statements below 1200,
+ ;; causing the build to fail prematurely.
+ (substitute* "contrib/generate_precompile.jl"
+ (("1200") "1100"))
+ #t))
;; For some reason libquadmath is unavailable on this architecture.
;; https://github.com/JuliaLang/julia/issues/41613
,@(if (target-aarch64?)
@@ -499,9 +505,6 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
"@test_broken ispath(ca_roots_path())")
(("@test ca_roots_path\\(\\) \\!= bundled_ca_roots\\(\\)")
"@test_broken ca_roots_path() != bundled_ca_roots()"))
- ;; Some digraphs are too wide for some terminals during testing.
- (substitute* "stdlib/Unicode/test/runtests.jl"
- (("test collect\\(graphemes") "test_broken collect(grapemes"))
;; WARNING: failed to select UTF-8 encoding, using ASCII
;; Using 'setlocale' doesn't affect the test failures.
;(setlocale LC_ALL "en_US.utf8")
@@ -659,8 +662,7 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
("dsfmt" ,dsfmt)
("libwhich" ,libwhich)))
(native-inputs
- `(("nss-certs" ,nss-certs)
- ("openssl" ,openssl)
+ `(("openssl" ,openssl)
("perl" ,perl)
("patchelf" ,patchelf)
("pkg-config" ,pkg-config)