summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-13 21:15:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-21 19:22:50 +0200
commitc3aef63223757650985647fe13dd70fe1b80b0d3 (patch)
treee7668d20e58058b1182e2f61d814481ae928801c /gnu/packages/julia-xyz.scm
parentc42652d57815a88b724f392bd32dcb5f71196939 (diff)
downloadguix-patches-c3aef63223757650985647fe13dd70fe1b80b0d3.tar
guix-patches-c3aef63223757650985647fe13dd70fe1b80b0d3.tar.gz
gnu: julia-chainrulescore: Update to 1.12.2.
* gnu/packages/julia-xyz.scm (julia-chainrulescore): Update to 1.12.2. [arguments]: Adjust 'adjust-tests phase for changes in the source.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 3a66bc1fa6..d6e301c5e8 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -776,7 +776,7 @@ execute forward-, reverse-, and mixed-mode primitives.")
(define-public julia-chainrulescore
(package
(name "julia-chainrulescore")
- (version "1.0.2")
+ (version "1.12.2")
(source
(origin
(method git-fetch)
@@ -785,7 +785,7 @@ execute forward-, reverse-, and mixed-mode primitives.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1866xv30h1bi7f2m993nljzf58wwmv8zlgn6ffn9j3wckch1nfpb"))))
+ (base32 "0lgfcsb7f6c7knhiz5dbqh8x47d370pn71y9ys2y6763g0b4pm61"))))
(build-system julia-build-system)
(arguments
(list
@@ -793,7 +793,9 @@ execute forward-, reverse-, and mixed-mode primitives.")
#~(modify-phases %standard-phases
(add-after 'unpack 'adjust-tests
(lambda _
- (substitute* "test/differentials/composite.jl"
+ (substitute* "test/tangent_types/tangent.jl"
+ ;; This test is disabled after the release.
+ (("@test haskey.*Float.*") "")
(("@test (.*construct)" _ test)
(string-append "@test_broken " test))))))))
(inputs ;required for tests