summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-01-04 23:47:53 +0100
committerEfraim Flashner <efraim@flashner.co.il>2022-01-10 15:15:37 +0200
commit5d697044a84b03e83ea4716022453cf0d26f6b4a (patch)
tree32f6f12540a0672a8e6cfb72ad11ebd8466ae112 /gnu/packages/julia-xyz.scm
parent46472ae54546853b3bde1c4e7ed74ec641ca0476 (diff)
downloadguix-patches-5d697044a84b03e83ea4716022453cf0d26f6b4a.tar
guix-patches-5d697044a84b03e83ea4716022453cf0d26f6b4a.tar.gz
gnu: Add julia-biosequences.
* gnu/packages/julia-xyz.scm (julia-biosequences): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index f747c72a42..27daf975f1 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -387,6 +387,37 @@ many of the other BioJulia packages. This package defines IO, exceptions, and
other types or methods used by other BioJulia packages.")
(license license:expat))))
+(define-public julia-biosequences
+ (package
+ (name "julia-biosequences")
+ (version "2.0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BioJulia/BioSequences.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ns6zk0zvnsf4hlsys9ck2xrn20qck0b0aghh484vc6n458zq2gw"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ (list julia-biogenerics
+ julia-biosymbols
+ julia-combinatorics
+ julia-indexablebitvectors
+ julia-stablerngs
+ julia-twiddle))
+ (native-inputs
+ (list julia-statsbase
+ julia-yaml))
+ (home-page "https://biojulia.net/BioSequences.jl/stable/")
+ (synopsis "Data types and methods for common operations with biological sequences")
+ (description "This package provides Data types and methods for common
+operations with biological sequences, including DNA, RNA, and amino acid
+sequences.")
+ (license license:expat)))
+
(define-public julia-biosymbols
(package
(name "julia-biosymbols")