summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-12-01 16:53:49 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-12-04 19:50:29 +0200
commit2a749f34e55becdf9aebb4b883022c7bd61fed45 (patch)
tree8025f8bf669ccd2bb430eccaf53b1e336202562c /gnu/packages/julia-xyz.scm
parent7fee8a46fbc1d8997a1df7d9705da019dfb7ec76 (diff)
downloadguix-patches-2a749f34e55becdf9aebb4b883022c7bd61fed45.tar
guix-patches-2a749f34e55becdf9aebb4b883022c7bd61fed45.tar.gz
gnu: julia-benchmarktools: Fix tests on i686-linux.
* gnu/packages/julia-xyz.scm (julia-benchmarktools)[arguments]<#:phases>: Conditionnally disable the failing tests. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 4c6f8c131c..6ef040f924 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -298,6 +298,25 @@ the entries on the bands.")
(sha256
(base32 "1xz3kdrphp4b158pg7dwkiry49phs2fjjpdvk1hjpww5ykxacks8"))))
(build-system julia-build-system)
+ (arguments
+ `(#:phases
+ ,@(if (target-x86-32?)
+ '((modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-tests-i686
+ (lambda _
+ (substitute* "test/GroupsTests.jl"
+ (("@test sprint\\(show, g1\\)")
+ "@test_broken sprint(show, g1)")
+ (("@test sprint\\(show, g1; context = :boundto => 1\\)")
+ "@test_broken sprint(show, g1; context = :boundto => 1)")
+ (("@test sprint\\(show, g1; context = :limit => false\\)")
+ "@test_broken sprint(show, g1; context = :limit => false)")
+ (("@test @test_deprecated") "@test_broken"))
+ (substitute* "test/ExecutionTests.jl"
+ ;; Evaluated: 12 == 8
+ (("@test @ballocated\\(Ref\\(1\\)\\)")
+ "@test_broken @ballocated(Ref(1))"))))))
+ '(%standard-phases))))
(propagated-inputs `(("julia-json" ,julia-json)))
(home-page "https://github.com/JuliaCI/BenchmarkTools.jl")
(synopsis "Benchmarking framework for the Julia language")