summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2021-04-24 19:33:27 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-03 23:10:02 +0200
commit64c1c497877d634a943e93c422b7beb61444b518 (patch)
tree597609d8b3277160fd5bd450276d2cdb29cebbaa /gnu/packages/julia-xyz.scm
parentcd95cb287e48fa4589fe813e150e2a31afa253b6 (diff)
downloadguix-patches-64c1c497877d634a943e93c422b7beb61444b518.tar
guix-patches-64c1c497877d634a943e93c422b7beb61444b518.tar.gz
gnu: Add julia-abstracttrees.
* gnu/packages/julia-xyz.scm (julia-abstracttrees): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 9812162ce1..21815387de 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -51,6 +51,29 @@ implement FFTs (such as @code{FFTW.jl} or @code{FastTransforms.jl}) extend the
types/functions defined in AbstractFFTs.")
(license license:expat)))
+(define-public julia-abstracttrees
+ (package
+ (name "julia-abstracttrees")
+ (version "0.3.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaCollections/AbstractTrees.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16is5n2qa69cci34vfazxsa7ik6q0hbnnqrbrhkq8frh142f1xs8"))))
+ (build-system julia-build-system)
+ (home-page "https://juliacollections.github.io/AbstractTrees.jl/stable/")
+ (synopsis "Abstract Julia interfaces for working with trees")
+ (description "This Julia package provides several utilities for working
+with tree-like data structures. Most importantly, it defines the
+@code{children} method that any package that contains such a data structure
+may import and extend in order to take advantage of any generic tree algorithm
+in this package.")
+ (license license:expat)))
+
(define-public julia-adapt
(package
(name "julia-adapt")