summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 09:46:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:48 +0300
commit0f6902ea79963a2c5d931414103de978a86f9dfd (patch)
tree2d05649ca7f64168fd89b276eee810d5e680f035 /gnu/packages/julia-xyz.scm
parentc00b1760f605255719a525e52c268b222a1f5184 (diff)
downloadguix-patches-0f6902ea79963a2c5d931414103de978a86f9dfd.tar
guix-patches-0f6902ea79963a2c5d931414103de978a86f9dfd.tar.gz
gnu: julia-jllwrappers: Move to (gnu packages julia-jll).
* gnu/packages/julia-xyz.scm (julia-jlwrappers): Move to ... * gnu/packages/julia-jll.scm: ... here. * gnu/local.mk (GNU_SYSTEM_MODULES): Register julia-jll.scm
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm44
1 files changed, 1 insertions, 43 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 551f016929..b8ba5bf93f 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -27,6 +27,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages julia-jll)
#:use-module (gnu packages maths)
#:use-module (gnu packages tls)
#:use-module (gnu packages web))
@@ -1077,49 +1078,6 @@ external IRs. It can be used with Julia metaprogramming tools such as
Cassette.")
(license license:expat)))
-(define-public julia-jllwrappers
- (package
- (name "julia-jllwrappers")
- (version "1.3.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/JuliaPackaging/JLLWrappers.jl")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0v7xhsv9z16d657yp47vgc86ggc01i1wigqh3n0d7i1s84z7xa0h"))))
- (arguments
- ;; Wants to download stuff
- '(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'custom-override-path
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Make @generate_wrapper_header take an optional argument that
- ;; guix packagers can pass to override the default "override"
- ;; binary path. This won't be needed when something like
- ;; https://github.com/JuliaPackaging/JLLWrappers.jl/pull/27
- ;; will be merged.
- (substitute* "src/wrapper_generators.jl"
- (("generate_wrapper_header.*")
- "generate_wrapper_header(src_name, override_path = nothing)\n")
- (("pkg_dir = .*" all)
- (string-append
- all "\n" "override = something(override_path,"
- "joinpath(dirname(pkg_dir), \"override\"))\n"))
- (("@static if isdir.*") "@static if isdir($override)\n")
- (("return joinpath.*") "return $override\n"))
- #t)))))
- (build-system julia-build-system)
- (home-page "https://github.com/JuliaPackaging/JLLWrappers.jl")
- (synopsis "Julia macros used by JLL packages")
- (description "This package contains Julia macros that enable JLL packages
-to generate themselves. It is not intended to be used by users, but rather is
-used in autogenerated packages via @code{BinaryBuilder.jl}.")
- (license license:expat)))
-
(define-public julia-jpegturbo-jll
(package
(name "julia-jpegturbo-jll")