summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 10:25:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:48 +0300
commitf0e0b9a55ac39da37bd0c75d7df6528118eba8cd (patch)
tree368629df192a06dbbfde6a222be5b1efdd65c34d /gnu/packages/julia-xyz.scm
parentcc54d4b6e2addd437aea70dd47632191cfb98645 (diff)
downloadguix-patches-f0e0b9a55ac39da37bd0c75d7df6528118eba8cd.tar
guix-patches-f0e0b9a55ac39da37bd0c75d7df6528118eba8cd.tar.gz
gnu: julia-jpegturbo-jll: Move to (gnu packages julia-jll).
* gnu/packages/julia-xyz.scm (julia-jpegturbo-jll): Move to ... * gnu/packages/julia-jll.scm: ... here.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm37
1 files changed, 0 insertions, 37 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 49439ae0a2..2a49cf5d6a 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -993,43 +993,6 @@ external IRs. It can be used with Julia metaprogramming tools such as
Cassette.")
(license license:expat)))
-(define-public julia-jpegturbo-jll
- (package
- (name "julia-jpegturbo-jll")
- (version "2.0.1+2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/JuliaBinaryWrappers/JpegTurbo_jll.jl")
- (commit (string-append "JpegTurbo-v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1xp1x0hrj337bgwwffwpyq7xg031j2a38fim29lixqa0a0y80x6y"))))
- (build-system julia-build-system)
- (arguments
- '(#:tests? #f ; no runtests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
- (lambda* (#:key inputs #:allow-other-keys)
- (map
- (lambda (wrapper)
- (substitute* wrapper
- (("artifact\"JpegTurbo\"")
- (string-append "\"" (assoc-ref inputs "libjpeg-turbo") "\""))))
- ;; There's a Julia file for each platform, override them all
- (find-files "src/wrappers/" "\\.jl$")))))))
- (inputs
- `(("libjpeg-turbo" ,libjpeg-turbo)))
- (propagated-inputs
- `(("julia-jllwrappers" ,julia-jllwrappers)))
- (home-page "https://github.com/JuliaBinaryWrappers/JpegTurbo_jll.jl")
- (synopsis "Libjpeg-turbo library wrappers")
- (description "This package provides a wrapper for the libjpeg-turbo library.")
- (license license:expat)))
-
(define-public julia-json
(package
(name "julia-json")