summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 10:39:07 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:49 +0300
commit8ca2dc09b7cf06e12bb43e41ac9dc852f495c1b4 (patch)
treed1e4dad2e04aca796a0f5b59e7034b5950403770 /gnu/packages/julia-xyz.scm
parent4a1d456a99948b75be078146b44b6e89880b9bc4 (diff)
downloadguix-patches-8ca2dc09b7cf06e12bb43e41ac9dc852f495c1b4.tar
guix-patches-8ca2dc09b7cf06e12bb43e41ac9dc852f495c1b4.tar.gz
gnu: julia-libpng-jll: Move to (gnu packages julia-jll).
* gnu/packages/julia-xyz.scm (julia-libpng-jll): Move to ... * gnu/packages/julia-jll.scm: ... here.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm38
1 files changed, 0 insertions, 38 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 3b73b4352b..659b490425 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1015,44 +1015,6 @@ Cassette.")
and printing JSON documents.")
(license license:expat)))
-(define-public julia-libpng-jll
- (package
- (name "julia-libpng-jll")
- (version "1.6.37+5")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/JuliaBinaryWrappers/LibPNG_jll.jl")
- (commit (string-append "libpng-v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "10azxv26j8r193dg9i9x7ajm3frhwbhj8zzi40fj59fxm81xz6dx"))))
- (build-system julia-build-system)
- (arguments
- '(#:tests? #f ; no runtests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
- (lambda* (#:key inputs #:allow-other-keys)
- (map
- (lambda (wrapper)
- (substitute* wrapper
- (("artifact\"libpng\"")
- (string-append "\"" (assoc-ref inputs "libpng") "\""))))
- ;; There's a Julia file for each platform, override them all
- (find-files "src/wrappers/" "\\.jl$")))))))
- (inputs
- `(("libpng" ,libpng)))
- (propagated-inputs
- `(("julia-jllwrappers" ,julia-jllwrappers)
- ("julia-zlib-jll" ,julia-zlib-jll)))
- (home-page "https://github.com/JuliaBinaryWrappers/LibPNG_jll.jl")
- (synopsis "Libpng library wrappers")
- (description "This package provides a wrapper for the libpng library.")
- (license license:expat)))
-
(define-public julia-libtiff-jll
(package
(name "julia-libtiff-jll")