summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-04 15:40:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-12 08:40:37 +0300
commit4ea3215d8f18453e6b8ff0a46654e52b5741c3e6 (patch)
treed65eaf6a2cb29692cda2352c8787e961a2518276 /gnu/packages/julia-xyz.scm
parentbfde12f7197fbc64f6be3fc1c818d9f22960582b (diff)
downloadguix-patches-4ea3215d8f18453e6b8ff0a46654e52b5741c3e6.tar
guix-patches-4ea3215d8f18453e6b8ff0a46654e52b5741c3e6.tar.gz
gnu: Add julia-bson.
* gnu/packages/julia-xyz.scm (julia-bson): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 9cd83281d1..a9ae66d588 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -368,6 +368,29 @@ A @code{BlockBandedMatrix} is a subtype of @code{BlockMatrix} of
@code{BlockArrays.jl} whose layout of non-zero blocks is banded.")
(license license:expat)))
+(define-public julia-bson
+ (package
+ (name "julia-bson")
+ (version "0.3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaIO/BSON.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1l5608ma2ys7v2gpcqbiv9mwfc6yrlqkihrfx1pf7fgv5llhd4fn"))))
+ (build-system julia-build-system)
+ (native-inputs
+ `(("julia-dataframes" ,julia-dataframes)))
+ (home-page "https://github.com/JuliaIO/BSON.jl")
+ (synopsis "Binary JSON serialisation format")
+ (description "@code{BSON.jl} is a Julia package for working with the Binary
+JSON serialisation format. It can be used as a general store for Julia data
+structures.")
+ (license license:expat)))
+
(define-public julia-bufferedstreams
(package
(name "julia-bufferedstreams")