summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 11:09:27 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:51 +0300
commit5cd1372745bb993654ca089cf0f75185de0eb2ec (patch)
tree8771e937d585e4c0cc036175fc5cd542ff5986d8 /gnu/packages/julia-jll.scm
parent92e817ea15c08654f8961d75fbd879266c3c9dad (diff)
downloadguix-patches-5cd1372745bb993654ca089cf0f75185de0eb2ec.tar
guix-patches-5cd1372745bb993654ca089cf0f75185de0eb2ec.tar.gz
gnu: Add julia-x265-jll.
* gnu/packages/julia-jll.scm (julia-x265-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 9e542fbf47..40d1d2bfb6 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -712,6 +712,42 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for the x264 video library.")
(license license:expat)))
+(define-public julia-x265-jll
+ (package
+ (name "julia-x265-jll")
+ (version "3.0.0+1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/x265_jll.jl")
+ (commit (string-append "x265-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "082jgjlc2zm9rzg8p7l9nd4hlg17ziwp2b8rrcpicpb6fxb7sjh4"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"x265\"")
+ (string-append "\"" (assoc-ref inputs "x265") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("x265" ,x265)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/x265_jll.jl")
+ (synopsis "x265 library wrappers")
+ (description "This package provides a wrapper for the x265 video library.")
+ (license license:expat)))
+
(define-public julia-zlib-jll
(package
(name "julia-zlib-jll")