summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 11:16:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:51 +0300
commitafff06e4cee2c4a40ddf8d3c072643b359e600d7 (patch)
tree0c8c3da820b761fba88a13ea130598a0a5cdf2bc /gnu/packages/julia-jll.scm
parenta18d0aac7ae02cff87aeda0ea0db24c854084910 (diff)
downloadguix-patches-afff06e4cee2c4a40ddf8d3c072643b359e600d7.tar
guix-patches-afff06e4cee2c4a40ddf8d3c072643b359e600d7.tar.gz
gnu: Add julia-opus-jll.
* gnu/packages/julia-jll.scm (julia-opus-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index acdfb926c7..904597a506 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -707,6 +707,42 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for the openssl library.")
(license license:expat)))
+(define-public julia-opus-jll
+ (package
+ (name "julia-opus-jll")
+ (version "1.3.1+1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Opus_jll.jl")
+ (commit (string-append "Opus-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zm0rnr3pi83bzza1azlrv8l7l0mjpykc3qz4b5p9zcdzf7aw4vn"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Opus\"")
+ (string-append "\"" (assoc-ref inputs "opus") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("opus" ,opus)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Opus_jll.jl")
+ (synopsis "Opus library wrappers")
+ (description "This package provides a wrapper for the opus audio library.")
+ (license license:expat)))
+
(define-public julia-x264-jll
(package
(name "julia-x264-jll")