summaryrefslogtreecommitdiff
path: root/gnu/packages/javascript.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/javascript.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/javascript.scm')
-rw-r--r--gnu/packages/javascript.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index 81de5b67a6..cdf9dd19fa 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -26,8 +26,8 @@
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
- #:use-module (gnu packages lisp-xyz)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages uglifyjs)
#:use-module (gnu packages web)
#:use-module (guix packages)
#:use-module (guix download)
@@ -163,14 +163,14 @@ context menu in TypeScript.")
(cond
((string-match "\\.js$" file)
(mkdir-p (dirname installed))
- (let ((minified (open-pipe* OPEN_READ "uglify-js" file)))
+ (let ((minified (open-pipe* OPEN_READ "uglifyjs" file)))
(call-with-output-file installed
(lambda (port)
(dump-port minified port)))
(let ((exit (close-pipe minified)))
(unless (zero? exit)
- (error "dear, uglify-js failed" exit)))))
+ (error "dear, uglifyjs failed" exit)))))
(else
(install-file file (dirname installed))))))
(find-files "."))
@@ -179,7 +179,7 @@ context menu in TypeScript.")
(native-inputs
`(("font-mathjax" ,font-mathjax)
("glibc-utf8-locales" ,glibc-utf8-locales)
- ("uglify-js" ,uglify-js)
+ ("uglifyjs" ,node-uglify-js)
,@(package-native-inputs font-mathjax)))
(synopsis "JavaScript display engine for LaTeX, MathML, and AsciiMath")
(description "MathJax is a JavaScript display engine for LaTeX, MathML,
@@ -527,8 +527,7 @@ means that these shams cause many ES5 methods to silently fail.")
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-uglification
- ;; Remove "export" keyword which prevents the file from being
- ;; uglified by uglify-js. Moreover, that keyword is not present in
+ ;; Remove "export" keyword. That keyword is not present in
;; the minified version of the library some projects are using,
;; e.g.,
;; <https://github.com/jmoenig/Snap--Build-Your-Own-Blocks/blob/master/FileSaver.min.js>