summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorArne Babenhauserheide <arne_bab@web.de>2021-12-02 22:59:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-02 23:58:53 +0100
commit68e71fbb174a680e89f3eb41540d187fdeb780fc (patch)
treee082805c1cd53888b1cbed34d8fe85001c7f06ce /gnu/packages/java.scm
parentf697fc267c317e98e4bba8009452b9d64e76b30a (diff)
downloadguix-patches-68e71fbb174a680e89f3eb41540d187fdeb780fc.tar
guix-patches-68e71fbb174a680e89f3eb41540d187fdeb780fc.tar.gz
gnu: Add openjdk17.
* gnu/packages/java.scm (openjdk17): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index da72dbb38c..8306dbf868 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2581,6 +2581,39 @@ new Date();"))
#t))))))
(home-page "https://openjdk.java.net/projects/jdk/16")))
+(define-public openjdk17
+ (package
+ (inherit openjdk16)
+ (name "openjdk")
+ (version "17.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openjdk/jdk17u")
+ (commit (string-append "jdk-" version "-ga"))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1l1jgbz8q7zq66npfg88r0l5xga427vrz35iys09j44b6qllrldd"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("openjdk16:jdk" ,openjdk16 "jdk")
+ ("pkg-config" ,pkg-config)
+ ("unzip" ,unzip)
+ ("which" ,which)
+ ("zip" ,zip)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments openjdk16)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'fix-java-shebangs
+ (lambda _
+ ;; This file was "fixed" by patch-source-shebangs, but it requires
+ ;; this exact first line.
+ (substitute* "make/data/blockedcertsconverter/blocked.certs.pem"
+ (("^#!.*") "#! java BlockedCertsConverter SHA-256\n"))))))))
+ (home-page "https://openjdk.java.net/projects/jdk/17")))
+
(define-public icedtea icedtea-8)