summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-15 15:03:29 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-15 15:03:29 +0200
commit988eb0d51245ded55b59b777e2733d396c478861 (patch)
tree644d3614b817e514b0817e7edea8a50e65f0932c /gnu/packages/java.scm
parenta2131c12bec62673bcd9bd51891df862884a1c37 (diff)
downloadguix-patches-988eb0d51245ded55b59b777e2733d396c478861.tar
guix-patches-988eb0d51245ded55b59b777e2733d396c478861.tar.gz
gnu: openjdk10: Fix build.
* gnu/packages/java.scm (openjdk10)[arguments]: Pass '-fcommon' to CFLAGS. Add 'disable-warnings-as-errors' phase. [native-inputs]: Add gcc-9.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 2a48612a81..9b0beaa541 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2138,6 +2138,7 @@ new Date();"))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(invoke "bash" "./configure"
+ "--with-extra-cflags=-fcommon"
(string-append "--with-freetype=" (assoc-ref inputs "freetype"))
"--disable-freetype-bundling"
"--disable-warnings-as-errors"
@@ -2145,13 +2146,19 @@ new Date();"))
"--with-giflib=system"
"--with-libjpeg=system"
"--with-native-debug-symbols=zipped"
- (string-append "--prefix=" (assoc-ref outputs "out")))
- #t))))
+ (string-append "--prefix=" (assoc-ref outputs "out")))))
+ (add-after 'unpack 'disable-warnings-as-errors
+ (lambda _
+ ;; It looks like the "--disable-warnings-as-errors" option of
+ ;; the 'configure' phase is not working.
+ (substitute* "make/autoconf/generated-configure.sh"
+ (("-Werror") ""))))))
((#:disallowed-references _ '())
`(,(gexp-input openjdk9)
,(gexp-input openjdk9 "jdk")))))
(native-inputs
- `(("openjdk9" ,openjdk9)
+ `(("gcc" ,gcc-9) ; FIXME: segmentation faults when using gcc-10.
+ ("openjdk9" ,openjdk9)
("openjdk9:jdk" ,openjdk9 "jdk")
("make@4.2" ,gnu-make-4.2)
("unzip" ,unzip)