summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2021-06-12 19:26:06 +0100
committerPierre Langlois <pierre.langlois@gmx.com>2021-06-13 17:44:50 +0100
commitafd4924d6a64c01a1d5138954b9f22c9bd4f4690 (patch)
treeb5d3035cb191a01a35af847c5a8edc33fe4566c8 /gnu/packages/java.scm
parent994235d956bc34dfcac17d7af230d3f581bdc3f8 (diff)
downloadguix-patches-afd4924d6a64c01a1d5138954b9f22c9bd4f4690.tar
guix-patches-afd4924d6a64c01a1d5138954b9f22c9bd4f4690.tar.gz
gnu: Add openjdk16.
* gnu/packages/java.scm (openjdk16): New variable.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index af3e83be00..471cc5e906 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2540,6 +2540,44 @@ new Date();"))
("zip" ,zip)))
(home-page "https://openjdk.java.net/projects/jdk/15")))
+(define-public openjdk16
+ (package
+ (inherit openjdk15)
+ (name "openjdk")
+ (version "16.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openjdk/jdk16u")
+ (commit (string-append "jdk-" version "-ga"))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ggddsbsar4dj2fycfqqqagqil7prhb30afvq6933rz7pa9apm2f"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("openjdk15:jdk" ,openjdk15 "jdk")
+ ("pkg-config" ,pkg-config)
+ ("unzip" ,unzip)
+ ("which" ,which)
+ ("zip" ,zip)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments openjdk15)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'make-templates-writable
+ (lambda _
+ ;; The build system copies a few .template files from the
+ ;; source directory into the build directory and then modifies
+ ;; them in-place. So these files have to be writable.
+ (for-each
+ (lambda (file)
+ (invoke "chmod" "u+w" file))
+ (find-files "src/java.base/share/classes/jdk/internal/misc/"
+ "\\.template$"))
+ #t))))))
+ (home-page "https://openjdk.java.net/projects/jdk/16")))
+
(define-public icedtea icedtea-8)