summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-10 22:41:08 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-23 22:54:12 +0200
commit90a127c7ed63c22485f0751f3c24a9072a05c8b8 (patch)
tree905f911c6906e3d2337c4882c6f94ca8a9384cc1 /gnu/packages/java.scm
parent1a6497dee43e7469040a6eb9dab101f6fc764eca (diff)
downloadguix-patches-90a127c7ed63c22485f0751f3c24a9072a05c8b8.tar
guix-patches-90a127c7ed63c22485f0751f3c24a9072a05c8b8.tar.gz
gnu: Add java-hdrhistogram.
* gnu/packages/web.scm (java-hdrhistogram): New variable.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 45cb16f1f6..901d16eabb 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -6020,3 +6020,42 @@ provides low-level abstractions (@code{JsonParser}, @code{JsonGenerator},
@code{JsonFactory}) as well as small number of higher level overrides needed to
make data-binding work.")
(license license:asl2.0))); found on wiki.fasterxml.com/JacksonLicensing
+
+(define-public java-hdrhistogram
+ (package
+ (name "java-hdrhistogram")
+ (version "2.1.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/HdrHistogram/HdrHistogram/"
+ "archive/HdrHistogram-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1sicbmc3sr42nw93qbkb26q9rn33ag33k6k77phjc3j5h5gjffqv"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "java-hdrhistogram.jar"
+ #:source-dir "src/main/java"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'set-version
+ (lambda _
+ (let* ((version-java "src/main/java/org/HdrHistogram/Version.java")
+ (template (string-append version-java ".template")))
+ (copy-file template version-java)
+ (substitute* version-java
+ (("\\$VERSION\\$") ,version)
+ (("\\$BUILD_TIME\\$") "0"))
+ #t))))))
+ (native-inputs
+ `(("junit" ,java-junit)
+ ("hamcrest" ,java-hamcrest-core)))
+ (home-page "https://hdrhistogram.github.io/HdrHistogram")
+ (synopsis "High dynamic range histogram")
+ (description "Hdrhistogram allows to create histograms that support
+recording and analyzing sampled data value counts across a configurable integer
+value range with configurable value precision within the range. Value precision
+is expressed as the number of significant digits in the value recording, and
+provides control over value quantization behavior across the value range and
+the subsequent value resolution at any given level.")
+ (license license:public-domain)))