summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-18 23:57:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-27 12:12:40 +0100
commitfc8d100b24dda625a2582ed7af7260dded770e8b (patch)
tree38f0e09634aa3996a6ea119b25be43e65d7279fd /gnu/packages/java.scm
parent933ad809f13ce8fa9bb32c43f68510bb942e5d88 (diff)
downloadguix-patches-fc8d100b24dda625a2582ed7af7260dded770e8b.tar
guix-patches-fc8d100b24dda625a2582ed7af7260dded770e8b.tar.gz
gnu: Add javacc.
* gnu/packages/java.scm (javacc): New variable.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index f49e313959..8683a86204 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1894,6 +1894,38 @@ designs.")
license:asl2.0
license:cpl1.0)))))
+(define-public javacc
+ (package
+ (name "javacc")
+ (version "7.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/javacc/javacc/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append "javacc-" version ".tar.gz"))
+ (sha256
+ (base32
+ "111xc9mnmc5a6qz6x3xbhqc07y1lg2b996ggzw0hrblg42zya9xf"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'delete-bundled-libs
+ (lambda _
+ (delete-file-recursively "lib") #t))
+ (replace 'install (install-jars "target")))))
+ (home-page "https://javacc.org/")
+ (synopsis "Java parser generator")
+ (description "Java Compiler Compiler (JavaCC) is the most popular parser
+generator for use with Java applications. A parser generator is a tool that
+reads a grammar specification and converts it to a Java program that can
+recognize matches to the grammar. In addition to the parser generator itself,
+JavaCC provides other standard capabilities related to parser generation such
+as tree building (via a tool called JJTree included with JavaCC), actions,
+debugging, etc.")
+ (license license:bsd-3)))
+
(define-public java-classpathx-servletapi
(package
(name "java-classpathx-servletapi")