summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-19 22:57:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-27 12:12:41 +0100
commit5e3abfc83f58cc9c5a9b62f1d54ee1fa76614ae4 (patch)
tree558a94ef7783640c2c31def941c4ddd716f50aa5 /gnu/packages/java.scm
parentc5ff11dcc160f589685f705f7713c94099067f44 (diff)
downloadguix-patches-5e3abfc83f58cc9c5a9b62f1d54ee1fa76614ae4.tar
guix-patches-5e3abfc83f58cc9c5a9b62f1d54ee1fa76614ae4.tar.gz
gnu: Add java-commons-bcel.
* gnu/packages/java.scm (java-commons-bcel): New variable.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 748da1d1ef..11fccba5dc 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -7236,6 +7236,41 @@ for high performance inter-thread communication that avoids the need for
message queues or resource locking.")
(license license:asl2.0)))
+(define-public java-commons-bcel
+ (package
+ (name "java-commons-bcel")
+ (version "6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://apache/commons/bcel/source/bcel-"
+ version "-src.tar.gz"))
+ (sha256
+ (base32
+ "0j3x1rxd673k07psclk8k13rqh0x0mf2yy5qiwkiw4z3afa568jy"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "bcel.jar"
+ #:jdk ,icedtea-8
+ #:source-dir "src/main/java"
+ #:test-dir "src/test/java"
+ ;; FIXME: Tests require the unpackaged jna.
+ #:tests? #f))
+ (home-page "https://commons.apache.org/proper/commons-bcel/")
+ (synopsis "Byte code engineering library")
+ (description "The Byte Code Engineering Library (Apache Commons BCEL) is
+intended to give users a convenient way to analyze, create, and
+manipulate (binary) Java class files. Classes are represented by objects
+which contain all the symbolic information of the given class: methods, fields
+and byte code instructions, in particular.
+
+Such objects can be read from an existing file, be transformed by a
+program (e.g. a class loader at run-time) and written to a file again. An
+even more interesting application is the creation of classes from scratch at
+run-time. The @dfn{Byte Code Engineering Library} (BCEL) may be also useful
+if you want to learn about the @dfn{Java Virtual Machine} (JVM) and the format
+of Java @code{.class} files.")
+ (license license:asl2.0)))
+
(define-public java-xerial-core
(package
(name "java-xerial-core")