summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-03 11:36:52 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-03 11:38:43 +0200
commit7f50543d55b20cd528b28d7e15f1bb81001a8da9 (patch)
tree3eb0d81cf85efdae52365c36ef6d2e3984f82dce /gnu/packages/java.scm
parent06247e465f98300ddc69a5384b103c8c1b9a866a (diff)
downloadguix-patches-7f50543d55b20cd528b28d7e15f1bb81001a8da9.tar
guix-patches-7f50543d55b20cd528b28d7e15f1bb81001a8da9.tar.gz
gnu: classpath-bootstrap: Work around miscompilation.
Fixes <https://issues.guix.gnu.org/49990>. Previously, building 'ant-bootstrap' would fail in obscure ways. * gnu/packages/patches/classpath-miscompilation.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/java.scm (classpath-bootstrap)[source]: Use it. [arguments]: Remove 'remove-call-to-free' phase.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index ed8c0c777d..51fc5c60a1 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -230,7 +230,8 @@ only faster.")
(sha256
(base32
"0i99wf9xd3hw1sj2sazychb9prx8nadxh2clgvk3zlmb28v0jbfz"))
- (patches (search-patches "classpath-aarch64-support.patch"))))
+ (patches (search-patches "classpath-aarch64-support.patch"
+ "classpath-miscompilation.patch"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -246,17 +247,6 @@ only faster.")
"--disable-gjdoc")
#:phases
(modify-phases %standard-phases
- ;; XXX: This introduces a memory leak as we remove a call to free up
- ;; memory for the file name string. This was necessary because of a
- ;; runtime error that would have prevented us from building
- ;; ant-bootstrap later. See https://issues.guix.gnu.org/issue/36685
- ;; for the gnarly details.
- (add-after 'unpack 'remove-call-to-free
- (lambda _
- (substitute* "native/jni/java-io/java_io_VMFile.c"
- (("result = cpio_isFileExists.*" m)
- (string-append m "\n//")))
- #t))
(add-after 'install 'install-data
(lambda _ (invoke "make" "install-data"))))))
(native-inputs