summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-10-05 14:17:25 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-10-05 14:17:25 +0200
commit87c079d9b55afda249ddc1b11798a62547a2cbb6 (patch)
treea7a0dbcfd8c3fb8935e00cc44f8b514fa790975b /gnu/packages/image.scm
parentde96ed11efdfb450ca45952aceda656a78d981c4 (diff)
parent3699ed63501a28629956ca60e198f5fafa57ad4e (diff)
downloadguix-patches-87c079d9b55afda249ddc1b11798a62547a2cbb6.tar
guix-patches-87c079d9b55afda249ddc1b11798a62547a2cbb6.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm39
1 files changed, 26 insertions, 13 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 68ca1b983b..410bf970f3 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2017, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015, 2016 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015, 2016, 2020 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015 Alex Kost <alezost@gmail.com>
;;; Copyright © 2014, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
@@ -129,7 +129,7 @@ code is Valgrind-clean and unit tested.")
(define-public libpng
(package
(name "libpng")
- (version "1.6.37")
+ (version "1.6.37") ; Remember to also update libpng-apng if possible!
(source (origin
(method url-fetch)
(uri (list (string-append "mirror://sourceforge/libpng/libpng16/"
@@ -162,7 +162,7 @@ library. It supports almost all PNG features and is extensible.")
(define-public libpng-apng
(package
(name "libpng-apng")
- (version "1.6.28")
+ (version "1.6.37")
(source
(origin
(method url-fetch)
@@ -176,7 +176,7 @@ library. It supports almost all PNG features and is extensible.")
"/libpng16/libpng-" version ".tar.xz")))
(sha256
(base32
- "0ylgyx93hnk38haqrh8prd3ax5ngzwvjqw5cxw7p9nxmwsfyrlyq"))))
+ "1jl8in381z0128vgxnvn33nln6hzckl7l7j9nqvkaf1m9n1p0pjh"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -210,7 +210,7 @@ library. It supports almost all PNG features and is extensible.")
version "/libpng-" version "-apng.patch.gz"))
(sha256
(base32
- "0m5nv70n9903x3xzxw9qqc6sgf2rp106ha0x6gix0xf8wcrljaab"))))))
+ "1dh0250mw9b2hx7cdmnb2blk7ddl49n6vx8zz7jdmiwxy38v4fw2"))))))
(native-inputs
`(("libtool" ,libtool)))
;; libpng.la says "-lz", so propagate it.
@@ -336,7 +336,7 @@ Currently all documentation resides in @file{pnglite.h}.")
(define-public libimagequant
(package
(name "libimagequant")
- (version "2.12.5")
+ (version "2.12.6")
(source
(origin
(method git-fetch)
@@ -345,7 +345,7 @@ Currently all documentation resides in @file{pnglite.h}.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0cp68w04ja5pv77ssfafsn958w9hh9zb8crrlb5j3gsrcmdc032k"))))
+ (base32 "00w7fny3xf14cfyhbdnmqyh9ddqdh1irvgzxd35a2z65kp7vnvj0"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f)) ; no check target
@@ -1411,7 +1411,7 @@ convert, manipulate, filter and display a wide variety of image formats.")
(define-public jasper
(package
(name "jasper")
- (version "2.0.19")
+ (version "2.0.21")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1420,8 +1420,20 @@ convert, manipulate, filter and display a wide variety of image formats.")
(file-name (git-file-name name version))
(sha256
(base32
- "036rcr0wkz9gzmvk1jb96piznk0c0bwxgf31z1zrlg8js4zl1n84"))))
+ "0p3qr4j4pjs5vn5amm6ih9hb4wmm72marhmfw08svcs4rrr88p9y"))))
(build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-checking-disabled-things
+ (lambda _
+ ;; The MIF codec was disabled for security reasons in JasPer 2.0.20
+ ;; but its test suite still assumes that the format is supported.
+ (for-each delete-file
+ (find-files "data/test" "\\.mif$")) ; for run_test_1
+ (substitute* "test/bin/run_test_2"
+ (("image_formats\\+=\\(mif\\)") ""))
+ #t)))))
(inputs `(("libjpeg" ,libjpeg-turbo)))
(synopsis "JPEG-2000 library")
(description "The JasPer Project is an initiative to provide a reference
@@ -1939,7 +1951,8 @@ identical visual appearance.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0fjmjq0ws9rlblkcqxxw2lv7zvvyi618jqzlnz5z9zb477jwdfib"))))
+ (base32 "0fjmjq0ws9rlblkcqxxw2lv7zvvyi618jqzlnz5z9zb477jwdfib"))
+ (patches (search-patches "grim-revert-output-rotation.patch"))))
(build-system meson-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("scdoc" ,scdoc)))
@@ -2170,12 +2183,12 @@ by AOM, including with alpha.")
`(("imlib2" ,imlib2)
("libtiff" ,libtiff)
("libpng" ,libpng)
- ("libungif", libungif)
- ("libjpeg", libjpeg-turbo)
+ ("libungif" ,libungif)
+ ("libjpeg" ,libjpeg-turbo)
("libwebp" ,libwebp)
("openjpeg" ,openjpeg)
("lcms" ,lcms)
- ("zlib", zlib)
+ ("zlib" ,zlib)
("glib" ,glib)
;; Support for gtk3 is in the testing stage.
("gtk+" ,gtk+-2)))