summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2020-11-15 00:43:27 +0800
committerEfraim Flashner <efraim@flashner.co.il>2020-11-24 11:10:23 +0200
commit98f5548cc71fec81728043b78b0668ac2dc1ca7d (patch)
treee8246f709d8566998b353e956049b1dd72be29f3 /gnu/packages/image.scm
parentc68a18df2f64a92776e8e55c2251c265401ba26b (diff)
downloadguix-patches-98f5548cc71fec81728043b78b0668ac2dc1ca7d.tar
guix-patches-98f5548cc71fec81728043b78b0668ac2dc1ca7d.tar.gz
gnu: flameshot: Update to 0.8.5.
* gnu/packages/image.scm(flameshot): Update to 0.8.5. [source, home-page]: Use new source URL. [build-system]: Use qt-build-system. [inputs]: Add qtsvg. [arguments]<phases>: Remove stale code. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm25
1 files changed, 10 insertions, 15 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 5f42924810..15dbe4cfed 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -90,6 +91,7 @@
#:use-module (guix build-system copy)
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
+ #:use-module (guix build-system qt)
#:use-module (guix build-system scons)
#:use-module (guix deprecation)
#:use-module (srfi srfi-1))
@@ -1789,33 +1791,26 @@ parsing, viewing, modifying, and saving this metadata.")
(define-public flameshot
(package
(name "flameshot")
- (version "0.5.1")
+ (version "0.8.5")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/lupoDharkael/flameshot")
+ (url "https://github.com/flameshot-org/flameshot")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "13h77np93r796jf289v4r687cmnpqkyqs34dm9gif4akaig74ky0"))))
- (build-system gnu-build-system)
+ "1z77igs60lz106vsf6wsayxjafxm3llf2lm4dpvsqyyrxybfq191"))))
+ (build-system qt-build-system)
(native-inputs
`(("qttools" ,qttools)))
(inputs
- `(("qtbase" ,qtbase)))
+ `(("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)))
(arguments
- `(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "qmake"
- "CONFIG+=packaging"
- (string-append "BASEDIR=" (assoc-ref outputs "out"))
- "PREFIX=/"))))))
- (home-page "https://github.com/lupoDharkael/flameshot")
+ `(#:tests? #f)) ;no tests
+ (home-page "https://github.com/flameshot-org/flameshot")
(synopsis "Powerful yet simple to use screenshot software")
(description "Flameshot is a screenshot program.
Features: