summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-11-25 20:15:17 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2016-11-29 19:15:47 +0100
commit37e05d64e4e0696988460d98514c7b1d5d89fd5a (patch)
tree356f706db4a5dd35265a7496ac45b8d74f3a254f /gnu/packages/image.scm
parentdc2ef09ad79803f2cc4828ef18927ca0e75e24fa (diff)
downloadguix-patches-37e05d64e4e0696988460d98514c7b1d5d89fd5a.tar
guix-patches-37e05d64e4e0696988460d98514c7b1d5d89fd5a.tar.gz
gnu: Add libjpeg-turbo.
* gnu/packages/image.scm (libjpeg-turbo): New variable.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 981e1f8109..3f9a2b2a4f 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -31,6 +31,7 @@
(define-module (gnu packages image)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
+ #:use-module (gnu packages assembly)
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages compression)
@@ -1016,3 +1017,33 @@ also converts external formats (BMP, GIF, PNM and TIFF) to optimized
PNG, and performs PNG integrity checks and corrections.")
(home-page "http://optipng.sourceforge.net/")
(license license:zlib)))
+
+(define-public libjpeg-turbo
+ (package
+ (name "libjpeg-turbo")
+ (version "1.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/" name "/" version "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0v365hm6z6lddcqagjj15wflk66rqyw75m73cqzl65rh4lyrshj1"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("nasm" ,nasm)))
+ (arguments
+ `(#:test-target "test"))
+ (home-page "http://www.libjpeg-turbo.org/")
+ (synopsis "SIMD-accelerated JPEG image handling library")
+ (description "libjpeg-turbo is a JPEG image codec that accelerates baseline
+JPEG compression and decompression using SIMD instructions: MMX on x86, SSE2 on
+x86-64, NEON on ARM, and AltiVec on PowerPC processors. Even on other systems,
+its highly-optimized Huffman coding routines allow it to outperform libjpeg by
+a significant amount.
+libjpeg-turbo implements both the traditional libjpeg API and the less powerful
+but more straightforward TurboJPEG API, and provides a full-featured Java
+interface. It supports color space extensions that allow it to compress from
+and decompress to 32-bit and big-endian pixel buffers (RGBX, XBGR, etc.).")
+ (license (list license:bsd-3 ; jsimd*.[ch] and most of simd/
+ license:ijg)))) ; the rest