summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-26 15:14:53 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-26 15:14:53 +0200
commite1556533d3e57950417b2e35a68e95c65fee5042 (patch)
tree41d67b065c7828e164af83254fb447849d9e880d /gnu/packages/image.scm
parent5d8d8f3b0a07edb3bd435830b076749f906537d8 (diff)
parent92f1cefb74f6092c0c70f93140824ab806086272 (diff)
downloadguix-patches-e1556533d3e57950417b2e35a68e95c65fee5042.tar
guix-patches-e1556533d3e57950417b2e35a68e95c65fee5042.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm39
1 files changed, 11 insertions, 28 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 1ba281205c..cee7f146fa 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -107,41 +107,24 @@ image files in PBMPLUS PPM/PGM, GIF, BMP, and Targa file formats.")
(define-public libtiff
(package
(name "libtiff")
- (version "4.0.3")
+ (version "4.0.5")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.remotesensing.org/pub/libtiff/tiff-"
version ".tar.gz"))
(sha256 (base32
- "0wj8d1iwk9vnpax2h29xqc2hwknxg3s0ay2d5pxkg59ihbifn6pa"))
- (patches (map search-patch '("libtiff-CVE-2012-4564.patch"
- "libtiff-CVE-2013-1960.patch"
- "libtiff-CVE-2013-1961.patch"
- "libtiff-CVE-2013-4231.patch"
- "libtiff-CVE-2013-4232.patch"
- "libtiff-CVE-2013-4244.patch"
- "libtiff-CVE-2013-4243.patch"
- "libtiff-CVE-2014-9330.patch"
- "libtiff-CVE-2014-8127-pt1.patch"
- "libtiff-CVE-2014-8127-pt2.patch"
- "libtiff-CVE-2014-8127-pt3.patch"
- "libtiff-CVE-2014-8127-pt4.patch"
- "libtiff-CVE-2014-8128-pt1.patch"
- "libtiff-CVE-2014-8128-pt2.patch"
- "libtiff-CVE-2014-8128-pt3.patch"
- "libtiff-CVE-2014-8129.patch"
- "libtiff-CVE-2014-9655.patch"
- "libtiff-CVE-2014-8128-pt4.patch"
- "libtiff-CVE-2014-8128-pt5.patch")))))
+ "171hgy4mylwmvdm7gp6ffjva81m4j56v3fbqsbfl7avzxn1slpp2"))))
(build-system gnu-build-system)
- (inputs `(("zlib" ,zlib)
- ("libjpeg-8" ,libjpeg-8)))
- ;; currently does not compile with libjpeg version 9
+ (outputs '("out"
+ "doc")) ;1.3 MiB of HTML documentation
(arguments
- `(#:configure-flags
- (list (string-append "--with-jpeg-include-dir="
- (assoc-ref %build-inputs "libjpeg-8")
- "/include"))))
+ ;; Instead of using --docdir, this package has its own --with-docdir.
+ `(#:configure-flags (list (string-append "--with-docdir="
+ (assoc-ref %outputs "doc")
+ "/share/doc/"
+ ,name "-" ,version))))
+ (inputs `(("zlib" ,zlib)
+ ("libjpeg" ,libjpeg)))
(synopsis "Library for handling TIFF files")
(description
"Libtiff provides support for the Tag Image File Format (TIFF), a format