summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-21 22:19:28 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:19 -0400
commit72096b733016f50e71f02a6558425d8659f8970c (patch)
treef658b4b6ee8a6d1e5129f2775d378c876a58204a /gnu/packages/image.scm
parente10e277f7a958c3f41285b08608c6ba96339c99d (diff)
downloadguix-patches-72096b733016f50e71f02a6558425d8659f8970c.tar
guix-patches-72096b733016f50e71f02a6558425d8659f8970c.tar.gz
gnu: Add converseen.
* gnu/packages/image.scm (converseen): New variable. * gnu/packages/patches/converseen-hide-non-free-pointers.patch: * gnu/packages/patches/converseen-hide-updates-checks.patch: New files. * gnu/local.mk: Register files above.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 37d01eb731..7858c24c3e 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022-2023 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -77,6 +78,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages graphics)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages imagemagick)
#:use-module (gnu packages lua)
#:use-module (gnu packages man)
#:use-module (gnu packages maths)
@@ -116,6 +118,50 @@
#:use-module (guix deprecation)
#:use-module (srfi srfi-1))
+(define-public converseen
+ (package
+ (name "converseen")
+ (version "0.9.11.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Faster3ck/Converseen")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nxvac8df47gxg1klqlz0s3rxl0ykrikmciniwkb938bgilmaijm"))
+ (patches
+ (search-patches "converseen-hide-updates-checks.patch"
+ ;; Remove links to sites relying on non-free
+ ;; Javascript.
+ "converseen-hide-non-free-pointers.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #false ;no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-translations-location
+ ;; Fix translations location. Without this, only English is
+ ;; offered.
+ (lambda _
+ (substitute* "src/translator.cpp"
+ (("QString\\(\"%1/share/converseen/loc\"\\).arg\\(rootPath\\)")
+ (string-append "QString(\""
+ #$output
+ "/share/converseen/loc\")"))))))))
+ (native-inputs
+ (list pkg-config qttools-5))
+ (inputs
+ (list imagemagick qtbase-5))
+ (home-page "https://converseen.fasterland.net/")
+ (synopsis "Batch image converter and resizer")
+ (description
+ "Converseen is an image batch conversion tool. You can resize and
+convert images in more than 100 different formats.")
+ (license license:gpl3+)))
+
(define-public iqa
(package
(name "iqa")