summaryrefslogtreecommitdiff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-14 08:55:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-14 08:57:48 +0200
commit3d15e9e5bcd7cdad33f9832e4956f494c47e1937 (patch)
tree4a698c48aac7c50a571b1ada218858d47ef3b45e /gnu/packages/image-processing.scm
parentf9f36b08e5e25282741da624647ea104cec764b5 (diff)
downloadguix-patches-3d15e9e5bcd7cdad33f9832e4956f494c47e1937.tar
guix-patches-3d15e9e5bcd7cdad33f9832e4956f494c47e1937.tar.gz
gnu: insight-toolkit-4.12: Fix building.
* gnu/packages/image-processing.scm (insight-toolkit-4.12)[arguments]: Add a configure-flag to build with c++14. Change-Id: I5e7a0a3ed47e4e3f25611147f8e66c58a1bf8a8c
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 9b633d5d63..36fee7e276 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -1412,7 +1412,12 @@ combine the information contained in both.")
(uri (string-append "mirror://sourceforge/itk/itk/4.12/"
"InsightToolkit-" version ".tar.xz"))
(sha256
- (base32 "1qw9mxbh083siljygahl4gdfv91xvfd8hfl7ghwii19f60xrvn2w"))))))
+ (base32 "1qw9mxbh083siljygahl4gdfv91xvfd8hfl7ghwii19f60xrvn2w"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments insight-toolkit-4)
+ ((#:configure-flags cf #~'())
+ ;; error: ISO C++17 does not allow dynamic exception specifications
+ #~(cons* "-DCMAKE_CXX_FLAGS=-std=c++14" #$cf))))))
(define-public itk-snap
(package