summaryrefslogtreecommitdiff
path: root/gnu/packages/i2p.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-06 21:16:32 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 21:16:32 +0200
commit8d59c262ada2e2167196a8fb8cbebd9c329a79dd (patch)
tree85a74de8cc23a2f0179c0b9f0adfa4c274449a0c /gnu/packages/i2p.scm
parente7f0835b07d868fd447aa64c873174fa385e1699 (diff)
parenta068ed6a5f5b3535fce49ac4eca1fec82edd6fdc (diff)
downloadguix-patches-8d59c262ada2e2167196a8fb8cbebd9c329a79dd.tar
guix-patches-8d59c262ada2e2167196a8fb8cbebd9c329a79dd.tar.gz
Merge branch 'master' into core-updates
Conflicts: gnu/local.mk gnu/packages/algebra.scm gnu/packages/bioinformatics.scm gnu/packages/curl.scm gnu/packages/docbook.scm gnu/packages/emacs-xyz.scm gnu/packages/maths.scm gnu/packages/plotutils.scm gnu/packages/python-web.scm gnu/packages/python-xyz.scm gnu/packages/radio.scm gnu/packages/readline.scm gnu/packages/tls.scm gnu/packages/xml.scm gnu/packages/xorg.scm
Diffstat (limited to 'gnu/packages/i2p.scm')
-rw-r--r--gnu/packages/i2p.scm74
1 files changed, 40 insertions, 34 deletions
diff --git a/gnu/packages/i2p.scm b/gnu/packages/i2p.scm
index 5698e6362c..1a9958c8d0 100644
--- a/gnu/packages/i2p.scm
+++ b/gnu/packages/i2p.scm
@@ -1,6 +1,8 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.org>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
+;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,7 +32,7 @@
(define-public i2pd
(package
(name "i2pd")
- (version "2.36.0")
+ (version "2.38.0")
(source
(origin
(method git-fetch)
@@ -39,40 +41,44 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0gx7y0vrg9lsl7m1r6c8xyyqmaqn900kms4g0941g0gd5zdb0mvz"))))
+ (base32 "1a35grcfw5a9dsj0rnm2i86fjf4px96xbnjj3hkril7hv5jvl37k"))))
(build-system cmake-build-system)
- (inputs `(("boost" ,boost)
- ("miniupnpc" ,miniupnpc)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
- (arguments '(#:configure-flags
- (let ((source (assoc-ref %build-inputs "source")))
- (list (string-append "-S" source "/build")
- "-DWITH_PCH=OFF"
- "-DWITH_STATIC=OFF"
- "-DWITH_UPNP=ON"
- "-DWITH_LIBRARY=ON"
- "-DBUILD_SHARED_LIBS=ON"
- "-DWITH_BINARY=ON"))
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key
- (make-flags '())
- (parallel-tests? #t)
- #:allow-other-keys)
- (let ((source (assoc-ref %build-inputs "source")))
- (copy-recursively (string-append source "/tests")
- "./tests")
- (with-directory-excursion "tests"
- (substitute* "Makefile"
- (("../libi2pd/") (string-append source "/libi2pd/")))
- (apply invoke "make" "all"
- `(,@(if parallel-tests?
- `("-j" ,(number->string
- (parallel-job-count)))
- '())
- ,@make-flags)))))))))
+ (inputs
+ `(("boost" ,boost)
+ ("miniupnpc" ,miniupnpc)
+ ("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (arguments
+ '(#:configure-flags
+ (let ((source (assoc-ref %build-inputs "source")))
+ (list (string-append "-S" source "/build")
+ "-DWITH_PCH=OFF"
+ "-DWITH_STATIC=OFF"
+ "-DWITH_UPNP=ON"
+ "-DWITH_LIBRARY=ON"
+ "-DBUILD_SHARED_LIBS=ON"
+ "-DWITH_BINARY=ON"))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key
+ tests?
+ (make-flags '())
+ (parallel-tests? #t)
+ #:allow-other-keys)
+ (let ((source (assoc-ref %build-inputs "source")))
+ (when tests?
+ (copy-recursively (string-append source "/tests")
+ "./tests")
+ (with-directory-excursion "tests"
+ (substitute* "Makefile"
+ (("../libi2pd/") (string-append source "/libi2pd/")))
+ (apply invoke "make" "all"
+ `(,@(if parallel-tests?
+ `("-j" ,(number->string
+ (parallel-job-count)))
+ '())
+ ,@make-flags))))))))))
(home-page "https://i2pd.website/")
(synopsis "Router for an end-to-end encrypted and anonymous internet")
(description "i2pd is a client for the anonymous I2P network, upon which