summaryrefslogtreecommitdiff
path: root/gnu/packages/i2p.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-03-05 22:56:40 +0000
committerChristopher Baines <mail@cbaines.net>2021-03-06 00:18:30 +0000
commita8448da0f4a090818104e64dd79f90b0e50d5e77 (patch)
tree494c58b4724f12cd9de0db9b0a7096de2b922c0f /gnu/packages/i2p.scm
parent4f4b749e75b38b8c08b4f67ef51c2c8740999e28 (diff)
parenta714af38d5d1046081524d859cde4cd8fd12a923 (diff)
downloadguix-patches-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar
guix-patches-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/i2p.scm')
-rw-r--r--gnu/packages/i2p.scm34
1 files changed, 4 insertions, 30 deletions
diff --git a/gnu/packages/i2p.scm b/gnu/packages/i2p.scm
index 537aeaf76c..5698e6362c 100644
--- a/gnu/packages/i2p.scm
+++ b/gnu/packages/i2p.scm
@@ -30,7 +30,7 @@
(define-public i2pd
(package
(name "i2pd")
- (version "2.31.0")
+ (version "2.36.0")
(source
(origin
(method git-fetch)
@@ -39,7 +39,7 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1q2gxz041ha9n5lfn91iy11sdf3z7d806vcq4z43m7lf92m7i4nn"))))
+ (base32 "0gx7y0vrg9lsl7m1r6c8xyyqmaqn900kms4g0941g0gd5zdb0mvz"))))
(build-system cmake-build-system)
(inputs `(("boost" ,boost)
("miniupnpc" ,miniupnpc)
@@ -66,39 +66,13 @@
"./tests")
(with-directory-excursion "tests"
(substitute* "Makefile"
- (("../libi2pd/") (string-append source "/libi2pd/"))
- ;; Disable the x25519 test, which only compiles if
- ;; openssl doesn't have X25519 support, but the
- ;; version we use has it.
- (("test-base-64 test-x25519 test-aeadchacha20poly1305")
- "test-base-64 test-aeadchacha20poly1305"))
+ (("../libi2pd/") (string-append source "/libi2pd/")))
(apply invoke "make" "all"
`(,@(if parallel-tests?
`("-j" ,(number->string
(parallel-job-count)))
'())
- ,@make-flags))))))
- (add-after 'install 'install-headers
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((install-dir (assoc-ref outputs "out"))
- (src-dir (string-append install-dir "/src"))
- (include-dir
- (string-append install-dir "/include")))
- (mkdir-p include-dir)
- ;; This is the only header file that's relevant to the
- ;; public interface.
- ;; <https://github.com/PurpleI2P/i2pd/issues/1378>
- (install-file (string-append src-dir "/api.h")
- include-dir)
- #t)))
- (add-after 'install-headers 'remove-source
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((install-dir (assoc-ref outputs "out"))
- (src-dir (string-append install-dir "/src")))
- (delete-file-recursively src-dir)
- (delete-file (string-append install-dir
- "/LICENSE"))
- #t))))))
+ ,@make-flags)))))))))
(home-page "https://i2pd.website/")
(synopsis "Router for an end-to-end encrypted and anonymous internet")
(description "i2pd is a client for the anonymous I2P network, upon which