summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 09:31:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:39 +0100
commite045c014b60dcd1078f3a5c77fb5c174702b6093 (patch)
tree9df22764f7cf8b948357c7185496ccb5a1a3d082 /gnu/packages/haskell.scm
parentee448389cd3fb39f0f366bb71c6e9008b95ecb0a (diff)
downloadguix-patches-e045c014b60dcd1078f3a5c77fb5c174702b6093.tar
guix-patches-e045c014b60dcd1078f3a5c77fb5c174702b6093.tar.gz
gnu: ghc-hslua: Update to 0.9.5.
* gnu/packages/haskell.scm (ghc-hslua): Update to 0.9.5. [inputs]: Update lua-5.1 to lua; add ghc-exceptions, ghc-fail, and ghc-mtl. [native-inputs]: Remove ghc-hspec, ghc-hspec-contrib, hspec-discover, and ghc-hunit; add ghc-tasty, ghc-tasty-expected-failure, ghc-tasty-hunit, and ghc-tasty-quickcheck.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3e57d18c4a..59769bc899 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5493,25 +5493,28 @@ TIFF and GIF formats.")
(define-public ghc-hslua
(package
(name "ghc-hslua")
- (version "0.4.1")
+ (version "0.9.5")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"hslua/hslua-" version ".tar.gz"))
(sha256
(base32
- "0gqp6qhp4v24kzv2j49kgk7bxqzw0w10x0zr0r2j9wkfavqb9wid"))))
+ "1j2zk7f7nyywg2b0n6kb2yf6ljc7cn2sk9jz0h76g3ag2b70l12n"))))
(build-system haskell-build-system)
(arguments
`(#:configure-flags '("-fsystem-lua")))
(inputs
- `(("lua" ,lua-5.1)
+ `(("lua" ,lua)
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-fail" ,ghc-fail)
+ ("ghc-mtl" ,ghc-mtl)
("ghc-text" ,ghc-text)))
(native-inputs
- `(("ghc-hspec" ,ghc-hspec)
- ("ghc-hspec-contrib" ,ghc-hspec-contrib)
- ("hspec-discover" ,hspec-discover)
- ("ghc-hunit" ,ghc-hunit)
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-expected-failure" ,ghc-tasty-expected-failure)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
("ghc-quickcheck" ,ghc-quickcheck)
("ghc-quickcheck-instances" ,ghc-quickcheck-instances)))
(home-page "https://hackage.haskell.org/package/hslua")