summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-11-05 18:58:41 +0100
committerDavid Craven <david@craven.ch>2016-12-10 21:47:08 +0100
commit60bc622b1d7e70bbc208bf1af356d1157196ae57 (patch)
tree988d6408abaa14d436505fed8e816d075426695c /gnu/packages/haskell.scm
parent3ea25176f0154b0cc3df4fc869350929760ccb98 (diff)
downloadguix-patches-60bc622b1d7e70bbc208bf1af356d1157196ae57.tar
guix-patches-60bc622b1d7e70bbc208bf1af356d1157196ae57.tar.gz
gnu: idris: Update to 0.12.3.
* gnu/packages/haskell.scm (idris): Update to 0.12.3. [origin]: Remove snippet. [inputs]: Add ghc-aeson, ghc-async, ghc-fsnotify, ghc-regex-tdfa, ghc-tasty-golden, ghc-tasty-rerun and ghc-terminal-size. [arguments]: Disable tests.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm62
1 files changed, 41 insertions, 21 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index f0c27cea6d..8e5927a00b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6670,34 +6670,47 @@ constant-time:
(license license:bsd-3)))
(define-public idris
+ ;; TODO: IDRIS_LIBRARY_PATH only accepts a single path and not a colon
+ ;; separated list.
+ ;; TODO: When installing idris the location of the standard libraries
+ ;; cannot be specified.
+ ;; NOTE: Creating an idris build system:
+ ;; Idris packages can be packaged and installed using a trivial
+ ;; build system.
+ ;; (zero? (system* (string-append idris "/bin/idris")
+ ;; "--ibcsubdir"
+ ;; (string-append out "/idris/libs/lightyear")
+ ;; "--install" "lightyear.ipkg")
+ ;; (native-search-paths
+ ;; (list (search-path-specification
+ ;; (variable "IDRIS_LIBRARY_PATH")
+ ;; (files '("idris/libs")))))
(package
(name "idris")
- (version "0.9.19.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://hackage.haskell.org/package/idris-"
- version "/idris-" version ".tar.gz"))
- (sha256
- (base32
- "10641svdsjlxbxmbvylpia04cz5nn9486lpiay8ibqcrc1792qgc"))
- (modules '((guix build utils)))
- (snippet
- '(substitute* "idris.cabal"
- ;; Package description file has a too-tight version restriction,
- ;; rendering it incompatible with GHC 7.10.2. This is fixed
- ;; upstream. See
- ;; <https://github.com/idris-lang/Idris-dev/issues/2734>.
- (("vector < 0.11") "vector < 0.12")))))
+ (version "0.12.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/"
+ "idris-" version "/idris-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ijrbgzaahw9aagn4al55nqcggrg9ajlrkq2fjc1saq3xdd3v7rs"))))
(build-system haskell-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-before 'configure 'patch-cc-command
- (lambda _
- (setenv "CC" "gcc"))))))
+ `(;; FIXME: runhaskell Setup.hs test doesn't set paths required by test
+ ;; suite.
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-cc-command
+ (lambda _
+ (setenv "CC" "gcc"))))))
(inputs
`(("gmp" ,gmp)
("ncurses" ,ncurses)
+ ("ghc-aeson" ,ghc-aeson)
+ ("ghc-async" ,ghc-async)
("ghc-annotated-wl-pprint" ,ghc-annotated-wl-pprint)
("ghc-ansi-terminal" ,ghc-ansi-terminal)
("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
@@ -6706,12 +6719,19 @@ constant-time:
("ghc-blaze-markup" ,ghc-blaze-markup)
("ghc-cheapskate" ,ghc-cheapskate)
("ghc-fingertree" ,ghc-fingertree)
+ ("ghc-fsnotify" ,ghc-fsnotify)
+ ("ghc-ieee754" ,ghc-ieee754)
("ghc-mtl" ,ghc-mtl)
("ghc-network" ,ghc-network)
("ghc-optparse-applicative" ,ghc-optparse-applicative)
("ghc-parsers" ,ghc-parsers)
+ ("ghc-regex-tdfa" ,ghc-regex-tdfa)
("ghc-safe" ,ghc-safe)
("ghc-split" ,ghc-split)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-golden" ,ghc-tasty-golden)
+ ("ghc-tasty-rerun" ,ghc-tasty-rerun)
+ ("ghc-terminal-size" ,ghc-terminal-size)
("ghc-text" ,ghc-text)
("ghc-trifecta" ,ghc-trifecta)
("ghc-uniplate" ,ghc-uniplate)