summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 00:18:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:38 +0100
commit0ffea6f2794c04123e4685933a7562a33fd9ad8a (patch)
tree005bd1045d5269cb37b00e29417a603af795d27c /gnu/packages/haskell.scm
parente80e97b52e4ba9a87e1a3af11bba45b9b7eebe24 (diff)
downloadguix-patches-0ffea6f2794c04123e4685933a7562a33fd9ad8a.tar
guix-patches-0ffea6f2794c04123e4685933a7562a33fd9ad8a.tar.gz
gnu: Add ghc-fixed.
* gnu/packages/haskell.scm (ghc-fixed): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9915b2f2fc..02d4033c93 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1270,6 +1270,26 @@ PNG, PNM, TGA, TIFF, XCF, XPM, XV.")
computation library for Haskell.")
(license license:bsd-3)))
+(define-public ghc-fixed
+ (package
+ (name "ghc-fixed")
+ (version "0.2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/fixed/fixed-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1qhmwx8iqshns0crmr9d2f8hm65jxbcp3dvv0c39v34ra7if3a94"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/ekmett/fixed")
+ (synopsis "Signed 15.16 precision fixed point arithmetic")
+ (description
+ "This package provides functions for signed 15.16 precision fixed point
+arithmetic.")
+ (license license:bsd-3)))
+
(define-public ghc-openglraw
(package
(name "ghc-openglraw")