summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 16:25:13 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 17:28:31 +0100
commit162a13740041f907f0ce5c2aa05b52b162b4e81a (patch)
tree33dc83f44d28063b4262e4f3477061407192c58e /gnu/packages/haskell.scm
parent28f6f22912ccbdbd485888c59ea263b8581027db (diff)
downloadguix-patches-162a13740041f907f0ce5c2aa05b52b162b4e81a.tar
guix-patches-162a13740041f907f0ce5c2aa05b52b162b4e81a.tar.gz
gnu: Consistently Write ‘file system(s)’.
It is the GNU way. * doc/guix.texi (Build Systems, DNS Services): Write ‘file system(s)’. * gnu/build/vm.scm (create-ext-file-system, create-fat-file-system): Likewise. * gnu/packages/backup.scm (dirvish, rsnapshot)[description]: Likewise. * gnu/packages/check.scm (python-testpath)[description]: Likewise. * gnu/packages/disk.scm (pydf)[description]: Likewise. * gnu/packages/file-systems.scm (disorderfs)[synopsis, description]: Likewise. (glusterfs)[description]: Likewise. * gnu/packages/haskell.scm (ghc-directory, ghc-system-fileio-bootstrap) (ghc-system-fileio)[synopsis]: Likewise. (ghc-fsnotify)[description]: Likewise. * gnu/packages/linux.scm (proot)[description]: Likewise. (jmtpfs)[synopsis, description]: Likewise. * gnu/packages/mate.scm (caja, caja-extensions)[description]: Likewise. * gnu/packages/storage.scm (ceph)[description]: Likewise. * gnu/packages/sync.scm (lsyncd)[description]: Likewise. * gnu/packages/syncthing.scm (syncthing)[synopsis]: Likewise. (go-github-com-zillode-notify)[description]: Likewise. * gnu/services/nfs.scm (pipefs-service-type): Likewise. * guix/scripts/system.scm (perform-action): Likewise.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e7ea2d8de1..21858e481c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5942,7 +5942,7 @@ supported. A module of colour names (\"Data.Colour.Names\") is provided.")
"0zkqihmdfz7bzv3sxh1p9ijl4vra880kfy3qy9h96flq7d2if0f2"))))
(build-system haskell-build-system)
(home-page "http://hackage.haskell.org/package/directory")
- (synopsis "Platform-agnostic library for filesystem operations")
+ (synopsis "Platform-agnostic library for file system operations")
(description
"This library provides a basic set of operations for manipulating
files and directories in a portable way.")
@@ -6203,7 +6203,7 @@ increasing type safety.")
("ghc-text" ,ghc-text)
("ghc-temporary" ,ghc-temporary)))
(home-page "https://github.com/fpco/haskell-filesystem")
- (synopsis "Consistent filesystem interaction across GHC versions")
+ (synopsis "Consistent file system interaction across GHC versions")
(description
"This is a small wrapper around the directory, unix, and Win32 packages,
for use with system-filepath. It provides a consistent API to the various
@@ -6424,7 +6424,7 @@ increasing type safety.")
("ghc-chell" ,ghc-chell)
("ghc-temporary" ,ghc-temporary)))
(home-page "https://github.com/fpco/haskell-filesystem")
- (synopsis "Consistent filesystem interaction across GHC versions")
+ (synopsis "Consistent file system interaction across GHC versions")
(description
"This is a small wrapper around the directory, unix, and Win32 packages,
for use with system-filepath. It provides a consistent API to the various
@@ -6744,7 +6744,7 @@ accessed or modified.")
(synopsis "Cross platform library for file change notification.")
(description "Cross platform library for file creation, modification, and
deletion notification. This library builds upon existing libraries for platform
-specific Windows, Mac, and Linux filesystem event notification.")
+specific Windows, Mac, and Linux file system event notification.")
(license license:bsd-3)))
(define-public ghc-ieee754