summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-29 00:54:58 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:19 +0200
commit955738723bd55b470feb33633da58fc76bada068 (patch)
tree9f5888a027953a0f7ab66986e643d2950440c428 /gnu/packages/haskell.scm
parent2d67fe8936f6f71493d97f40654d7931ef3621c0 (diff)
downloadguix-patches-955738723bd55b470feb33633da58fc76bada068.tar
guix-patches-955738723bd55b470feb33633da58fc76bada068.tar.gz
gnu: ghc-free: Update to 5.0.2.
* gnu/packages/haskell.scm (ghc-free): Update to 5.0.2. [inputs]: Add ghc-transformers-base and ghc-transformers-compat.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index bb08f3f096..e9dac65588 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5046,7 +5046,7 @@ semigroup.")
(define-public ghc-free
(package
(name "ghc-free")
- (version "4.12.4")
+ (version "5.0.2")
(source
(origin
(method url-fetch)
@@ -5056,7 +5056,7 @@ semigroup.")
".tar.gz"))
(sha256
(base32
- "1147s393442xf4gkpbq0rd1p286vmykgx85mxhk5d1c7wfm4bzn9"))))
+ "15m3n9vhz7z3kzv1w3wlfa3x8jp4cbrkwmrcjr7jlx39iqffn1gg"))))
(build-system haskell-build-system)
(inputs
`(("ghc-prelude-extras" ,ghc-prelude-extras)
@@ -5066,7 +5066,9 @@ semigroup.")
("ghc-comonad" ,ghc-comonad)
("ghc-distributive" ,ghc-distributive)
("ghc-semigroupoids" ,ghc-semigroupoids)
- ("ghc-semigroups" ,ghc-semigroups)))
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-transformers-base" ,ghc-transformers-base)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)))
(home-page "https://github.com/ekmett/free/")
(synopsis "Unrestricted monads for Haskell")
(description "This library provides free monads, which are useful for many