summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-02 01:14:53 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-02 15:52:55 +0100
commit467834d5505473dc853677be4ca7d151e28fd669 (patch)
tree449327e76fd0914f644fcecf215a6220c9dc3fb8 /gnu/packages/haskell.scm
parentd338321ddbd8545ff711254abc5d80c5b8cb3698 (diff)
downloadguix-patches-467834d5505473dc853677be4ca7d151e28fd669.tar
guix-patches-467834d5505473dc853677be4ca7d151e28fd669.tar.gz
gnu: ghc-abstract-deque: Fix typos in description.
* gnu/packages/haskell.scm (ghc-abstract-deque)[description]: Fix typos.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5c6e07a671..3ff78047db 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8181,12 +8181,12 @@ Background: There exists a feature space for queues that extends between:
@itemize
@item Simple, single-ended, non-concurrent, bounded queues
-@item Double-ended, threadsafe, growable queues with important points
-inbetween (such as the queues used for work-stealing).
+@item Double-ended, thread-safe, growable queues with important points
+in between (such as the queues used for work stealing).
@end itemize
This package includes an interface for Deques that allows the programmer
-to use a single API for all of the above, while using the type-system to
+to use a single API for all of the above, while using the type system to
select an efficient implementation given the requirements (using type families).
This package also includes a simple reference implementation based on