summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2017-08-07 15:02:41 +0800
committerRicardo Wurmus <rekado@elephly.net>2017-08-16 17:07:38 +0200
commitca48a3459413edd3a337b554ac0499c9f12364e6 (patch)
tree04a0a7517e3ec7515e04389b6a67cc1b05808264 /gnu/packages/haskell.scm
parentadcb30642cc8a7c6f845c22a3c066ae68fe2c64a (diff)
downloadguix-patches-ca48a3459413edd3a337b554ac0499c9f12364e6.tar
guix-patches-ca48a3459413edd3a337b554ac0499c9f12364e6.tar.gz
gnu: Add ghc-data-hash.
* gnu/packages/haskell.scm (ghc-data-hash): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 94445cb80a..00c5994016 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1858,6 +1858,29 @@ data structures. The package provides instances for basic types and a way to
combine hash values.")
(license license:bsd-3)))
+(define-public ghc-data-hash
+ (package
+ (name "ghc-data-hash")
+ (version "0.2.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/data-hash"
+ "/data-hash-" version ".tar.gz"))
+ (sha256
+ (base32 "1ghbqvc48gf9p8wiy71hdpaj7by3b9cw6wgwi3qqz8iw054xs5wi"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
+ (home-page "https://hackage.haskell.org/package/data-hash")
+ (synopsis "Combinators for building fast hashing functions")
+ (description
+ "This package provides combinators for building fast hashing functions.
+It includes hashing functions for all basic Haskell98 types.")
+ (license license:bsd-3)))
+
(define-public ghc-hunit
(package
(name "ghc-hunit")