summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2017-08-06 23:41:38 +0800
committerRicardo Wurmus <rekado@elephly.net>2017-08-16 16:53:13 +0200
commitbe04f8020a4208a82c7780ac2013f64b88dc8aee (patch)
treee1b920a000e7d6aec327ae71137a61786cda78c9 /gnu/packages/haskell.scm
parent867ed9776c160d4d1f1d05b005c0222584a92068 (diff)
downloadguix-patches-be04f8020a4208a82c7780ac2013f64b88dc8aee.tar
guix-patches-be04f8020a4208a82c7780ac2013f64b88dc8aee.tar.gz
gnu: Add ghc-edit-distance.
* gnu/packages/haskell.scm (ghc-edit-distance): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 59d19dd149..cdd47b37f1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6099,6 +6099,31 @@ supports for high level forms of ASN1 (BER, and DER).")
when ASN1 pattern matching is not convenient.")
(license license:bsd-3)))
+(define-public ghc-edit-distance
+ (package
+ (name "ghc-edit-distance")
+ (version "0.2.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/edit-distance"
+ "/edit-distance-" version ".tar.gz"))
+ (sha256
+ (base32 "0jkca97zyv23yyilp3jydcrzxqhyk27swhzh82llvban5zp8b21y"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-random" ,ghc-random)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
+ (home-page "https://github.com/phadej/edit-distance")
+ (synopsis "Levenshtein and restricted Damerau-Levenshtein edit distances")
+ (description
+ "This package provides optimized functions to determine the edit
+distances for fuzzy matching, including Levenshtein and restricted
+Damerau-Levenshtein algorithms.")
+ (license license:bsd-3)))
+
(define-public ghc-tasty-kat
(package
(name "ghc-tasty-kat")