summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-06-15 01:23:52 +0000
committerLudovic Courtès <ludo@gnu.org>2017-06-16 10:28:50 +0200
commitb202cc6ed593b4271c63f3eadaa4e113246add2c (patch)
tree487b1d773119bdc1160713fb2e9f0120282b5b23 /gnu/packages/haskell.scm
parent4031fb60ce8733b4508b05c77240ce169afd7b4c (diff)
downloadguix-patches-b202cc6ed593b4271c63f3eadaa4e113246add2c.tar
guix-patches-b202cc6ed593b4271c63f3eadaa4e113246add2c.tar.gz
gnu: Add ghc-http2.
* gnu/packages/haskell.scm (ghc-http2): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9849f24857..c4498edc06 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8490,4 +8490,40 @@ Typical applications of Priority Search Queues include:
matching patterns against file paths.")
(license license:bsd-3)))
+(define-public ghc-http2
+ (package
+ (name "ghc-http2")
+ (version "1.6.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "http2-" version "/"
+ "http2-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hww0rfsv6lqx62qzycbcqy5q6rh9k09qkyjkdm5m1sp1z50wqk1"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-bytestring-builder" ,ghc-bytestring-builder)
+ ("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-aeson" ,ghc-aeson)
+ ("ghc-aeson-pretty" ,ghc-aeson-pretty)
+ ("ghc-hex" ,ghc-hex)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-word8" ,ghc-word8)
+ ("ghc-psqueues" ,ghc-psqueues)
+ ("ghc-stm" ,ghc-stm)))
+ (native-inputs
+ `(("ghc-glob" ,ghc-glob)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-doctest" ,ghc-doctest)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page "https://github.com/kazu-yamamoto/http2")
+ (synopsis "HTTP/2 library including frames, priority queues and HPACK")
+ (description "This package provides a HTTP/2.0 library including frames
+and HPACK. Currently HTTP/2 16 framing and HPACK 10 is supported.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here