summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2017-08-07 15:22:00 +0800
committerRicardo Wurmus <rekado@elephly.net>2017-08-16 17:07:39 +0200
commitaf4db693dbb2413b910212ff6104f6086d8389fe (patch)
tree51edb06964cd1c7e538c15a9c441c14ebcaaec37 /gnu/packages/haskell.scm
parente0ca14c7a8557e3b96ad70fa43b8777ce4835ac5 (diff)
downloadguix-patches-af4db693dbb2413b910212ff6104f6086d8389fe.tar
guix-patches-af4db693dbb2413b910212ff6104f6086d8389fe.tar.gz
gnu: Add ghc-gitrev.
* gnu/packages/haskell.scm (ghc-gitrev): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 14cc228d5f..4f9e90e552 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5797,6 +5797,28 @@ maintained mirror of the @uref{https://hackage.haskell.org/package/geniplate,
geniplate} package, written by Lennart Augustsson.")
(license license:bsd-3)))
+(define-public ghc-gitrev
+ (package
+ (name "ghc-gitrev")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/gitrev/gitrev-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0cl3lfm6k1h8fxp2vxa6ihfp4v8igkz9h35iwyq2frzm4kdn96d8"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-base-compat" ,ghc-base-compat)))
+ (home-page "https://github.com/acfoltzer/gitrev")
+ (synopsis "Compile git revision info into Haskell projects")
+ (description
+ "This package provides some handy Template Haskell splices for including
+the current git hash and branch in the code of your project. This is useful
+for including in panic messages, @command{--version} output, or diagnostic
+info for more informative bug reports.")
+ (license license:bsd-3)))
+
(define-public ghc-haskell-src-meta
(package
(name "ghc-haskell-src-meta")