summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-02-24 06:29:31 +0000
committerLudovic Courtès <ludo@gnu.org>2017-03-11 12:43:36 +0100
commita15638034ef3d7bcfabe365b2f222479c8608ddd (patch)
tree2ae21ddaa85c10744f18c8297bacae2a4fa1651d /gnu/packages/haskell.scm
parent55fa53491b18bac6683eefb16ab70e6dc13869ef (diff)
downloadguix-patches-a15638034ef3d7bcfabe365b2f222479c8608ddd.tar
guix-patches-a15638034ef3d7bcfabe365b2f222479c8608ddd.tar.gz
gnu: Add ghc-unexceptionalio.
* gnu/packages/haskell.scm (ghc-unexceptionalio): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d0f659f6e3..2415881e8e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8194,4 +8194,22 @@ or filter messages based on the priority and source. It also has a syslog
handler built in.")
(license license:bsd-3)))
+(define-public ghc-unexceptionalio
+ (package
+ (name "ghc-unexceptionalio")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "unexceptionalio-" version "/" "unexceptionalio-"
+ version ".tar.gz"))
+ (sha256 (base32 "1f7h7zwky4scdcyjspg4ksfh7x6yra0wjybxq70p7vcwpgk2nzlj"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/singpolyma/unexceptionalio")
+ (synopsis "IO without any non-error, synchronous exceptions")
+ (description "When you've caught all the exceptions that can be
+handled safely, this is what you're left with.")
+ (license license:isc)))
+
;;; haskell.scm ends here