summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2017-08-06 23:43:53 +0800
committerRicardo Wurmus <rekado@elephly.net>2017-08-16 16:53:13 +0200
commit96f23b62e019919df73d3545806b1b85ee7540b5 (patch)
tree030c8423d6a1dd2e4eff7bb70f738d98f990557f /gnu/packages/haskell.scm
parent3f8b8e731c9c16190fa02ef15726795896923bf8 (diff)
downloadguix-patches-96f23b62e019919df73d3545806b1b85ee7540b5.tar
guix-patches-96f23b62e019919df73d3545806b1b85ee7540b5.tar.gz
gnu: Add ghc-equivalence.
* gnu/packages/haskell.scm (ghc-equivalence): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a1a37ce2e4..94445cb80a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4715,6 +4715,35 @@ definition of @code{Monad}.")
for Haskell.")
(license license:bsd-3)))
+(define-public ghc-equivalence
+ (package
+ (name "ghc-equivalence")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/equivalence"
+ "/equivalence-" version ".tar.gz"))
+ (sha256
+ (base32 "0a85bdyyvjqs5z4kfhhf758210k9gi9dv42ik66a3jl0z7aix8kx"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-mtl" ,ghc-mtl)
+ ("ghc-stmonadtrans" ,ghc-stmonadtrans)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
+ (home-page "https://github.com/pa-ba/equivalence")
+ (synopsis "Maintaining an equivalence relation implemented as union-find")
+ (description
+ "This is an implementation of Tarjan's Union-Find algorithm (Robert E.@:
+Tarjan. \"Efficiency of a Good But Not Linear Set Union Algorithm\",JACM
+22(2), 1975) in order to maintain an equivalence relation. This
+implementation is a port of the @code{union-find} package using the @code{ST}
+monad transformer (instead of the IO monad).")
+ (license license:bsd-3)))
+
(define-public ghc-fast-logger
(package
(name "ghc-fast-logger")