summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-02-11 20:35:05 +0000
committerLudovic Courtès <ludo@gnu.org>2017-02-13 15:55:55 +0100
commit5f622de13b604505898b372d7b87d6012ae2d561 (patch)
tree37ae2cde3151fb1c78ff3d568ed5e5a0f95d67a0 /gnu/packages/haskell.scm
parent3adab88faf7e1052861f36676f13d5d7359e809e (diff)
downloadguix-patches-5f622de13b604505898b372d7b87d6012ae2d561.tar
guix-patches-5f622de13b604505898b372d7b87d6012ae2d561.tar.gz
gnu: Add ghc-hslogger.
* gnu/packages/haskell.scm (ghc-hslogger): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index f9534b3275..d0f659f6e3 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8165,4 +8165,33 @@ Rust syntax. It is intended to be useful for two different purposes:
files in Haskell.")
(license license:bsd-3)))
+(define-public ghc-hslogger
+ (package
+ (name "ghc-hslogger")
+ (version "1.2.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "hslogger-" version "/" "hslogger-"
+ version ".tar.gz"))
+ (sha256 (base32
+ "0as5gvlh6pi2gflakp695qnlizyyp059dqrhvjl4gjxalja6xjnp"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-mtl" ,ghc-mtl)
+ ("ghc-network" ,ghc-network)
+ ("ghc-directory", ghc-directory)
+ ("ghc-old-locale" ,ghc-old-locale)
+ ("ghc-process" ,ghc-process)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)))
+ (home-page "http://software.complete.org/hslogger")
+ (synopsis "Logging framework for Haskell, similar to Python's logging module")
+ (description "Hslogger lets each log message have a priority and source be
+associated with it. The programmer can then define global handlers that route
+or filter messages based on the priority and source. It also has a syslog
+handler built in.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here