summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-06-15 01:23:51 +0000
committerLudovic Courtès <ludo@gnu.org>2017-06-16 10:28:26 +0200
commit4031fb60ce8733b4508b05c77240ce169afd7b4c (patch)
tree8e9c3b5c39808c05b9ec7cce9506c0c7de729af6 /gnu/packages/haskell.scm
parentaba85f8c385e6c4c67bd786fcc253413ff186c1f (diff)
downloadguix-patches-4031fb60ce8733b4508b05c77240ce169afd7b4c.tar
guix-patches-4031fb60ce8733b4508b05c77240ce169afd7b4c.tar.gz
gnu: Add ghc-glob.
* gnu/packages/haskell.scm (ghc-glob): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 26a3d9a183..9849f24857 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8460,4 +8460,34 @@ Typical applications of Priority Search Queues include:
@end itemize")
(license license:bsd-3)))
+(define-public ghc-glob
+ (package
+ (name "ghc-glob")
+ (version "0.7.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "Glob-" version "/"
+ "Glob-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0aw43izg8vlvjl40ms6k92w7gxg7n3l6smdvzla47fp82s4vhdr8"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-dlist" ,ghc-dlist)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
+ (home-page "http://iki.fi/matti.niemenmaa/glob/")
+ (synopsis "Haskell library matching glob patterns against file paths")
+ (description "This package providesa Haskell library for globbing:
+matching patterns against file paths.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here