summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2017-08-06 23:42:32 +0800
committerRicardo Wurmus <rekado@elephly.net>2017-08-16 16:53:13 +0200
commit3f8b8e731c9c16190fa02ef15726795896923bf8 (patch)
tree038741ce504eda78353bb65d09a1d647c29b4dfd /gnu/packages/haskell.scm
parentbe04f8020a4208a82c7780ac2013f64b88dc8aee (diff)
downloadguix-patches-3f8b8e731c9c16190fa02ef15726795896923bf8.tar
guix-patches-3f8b8e731c9c16190fa02ef15726795896923bf8.tar.gz
gnu: Add ghc-boxes.
* gnu/packages/haskell.scm (ghc-boxes): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index cdd47b37f1..a1a37ce2e4 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5102,6 +5102,28 @@ prettified JSON to stdout. It also offers a complementary \"compact\"-mode,
essentially the opposite of pretty-printing.")
(license license:bsd-3)))
+(define-public ghc-boxes
+ (package
+ (name "ghc-boxes")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/boxes/boxes-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1n7xiplzd3s1a39nizwjcgsh3wi2348mp21c3fk19v98ialfjgjf"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-split" ,ghc-split)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "https://hackage.haskell.org/package/boxes")
+ (synopsis "2D text pretty-printing library")
+ (description
+ "Boxes is a pretty-printing library for laying out text in two dimensions,
+using a simple box model.")
+ (license license:bsd-3)))
+
(define-public ghc-wai
(package
(name "ghc-wai")