summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2017-08-07 15:10:39 +0800
committerRicardo Wurmus <rekado@elephly.net>2017-08-16 17:07:39 +0200
commit1eced2a7a8a242b1aa0c8343ff6fcd43d2f457cb (patch)
tree603a87fd2278930d05c233daaa64cc46424137eb /gnu/packages/haskell.scm
parent212ae095414d6db2c44593a8da080b32259f30bc (diff)
downloadguix-patches-1eced2a7a8a242b1aa0c8343ff6fcd43d2f457cb.tar
guix-patches-1eced2a7a8a242b1aa0c8343ff6fcd43d2f457cb.tar.gz
gnu: Add ghc-edisoncore.
* gnu/packages/haskell.scm (ghc-edisoncore): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index fd8f78932b..552c57ddc5 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3897,6 +3897,30 @@ Collections such as sets, bags and heaps; and Associative Collections such as
finite maps and priority queues where the priority and element are distinct.")
(license license:expat)))
+(define-public ghc-edisoncore
+ (package
+ (name "ghc-edisoncore")
+ (version "1.3.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/EdisonCore"
+ "/EdisonCore-" version ".tar.gz"))
+ (sha256
+ (base32 "06shxmcqxcahcn6zgl64vlqix4fnq53d97drcgsh94qp7gp201ry"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-mtl" ,ghc-mtl)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-edisonapi" ,ghc-edisonapi)))
+ (home-page "http://rwd.rdockins.name/edison/home/")
+ (synopsis "Library of efficent, purely-functional data structures")
+ (description
+ "This package provides the core Edison data structure implementations,
+including multiple sequence, set, bag, and finite map concrete implementations
+with various performance characteristics.")
+ (license license:expat)))
+
(define-public ghc-mmorph
(package
(name "ghc-mmorph")