summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-13 23:08:49 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-03-13 23:08:49 +0200
commit3f9543aee1e49001d0f80542dd71ba73c44787c7 (patch)
tree50ee1bdd53b1e5ec69cb8655f23da79c332dde1e /gnu/packages/haskell.scm
parent864a9590ad948df09f2ad6e9e929608a7587a5f7 (diff)
parenta71c863834448e2645518b31b60a96ef488dd761 (diff)
downloadguix-patches-3f9543aee1e49001d0f80542dd71ba73c44787c7.tar
guix-patches-3f9543aee1e49001d0f80542dd71ba73c44787c7.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d0f659f6e3..2415881e8e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8194,4 +8194,22 @@ or filter messages based on the priority and source. It also has a syslog
handler built in.")
(license license:bsd-3)))
+(define-public ghc-unexceptionalio
+ (package
+ (name "ghc-unexceptionalio")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "unexceptionalio-" version "/" "unexceptionalio-"
+ version ".tar.gz"))
+ (sha256 (base32 "1f7h7zwky4scdcyjspg4ksfh7x6yra0wjybxq70p7vcwpgk2nzlj"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/singpolyma/unexceptionalio")
+ (synopsis "IO without any non-error, synchronous exceptions")
+ (description "When you've caught all the exceptions that can be
+handled safely, this is what you're left with.")
+ (license license:isc)))
+
;;; haskell.scm ends here